aboutsummaryrefslogtreecommitdiff
path: root/libs/avro
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-04-04 14:28:55 -0700
committerRosen Penev <rosenp@gmail.com>2020-04-09 00:57:29 -0700
commitbb196a7727e0a048d45662871fceedca67ec8fd6 (patch)
treeeb7615bec82c7677f2b911e55b274ba72e49f10d /libs/avro
parent54b54275363af21fa85aef097ecd94934e60cc69 (diff)
avro: remove
Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs/avro')
-rw-r--r--libs/avro/Makefile66
-rw-r--r--libs/avro/patches/010-pkgconfig.patch30
-rw-r--r--libs/avro/patches/020-bin-shared.patch27
-rw-r--r--libs/avro/patches/030-ssize_t.patch11
4 files changed, 0 insertions, 134 deletions
diff --git a/libs/avro/Makefile b/libs/avro/Makefile
deleted file mode 100644
index ebd842dd7..000000000
--- a/libs/avro/Makefile
+++ /dev/null
@@ -1,66 +0,0 @@
-#
-# avro - Makefile for Apache Avro library
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=avro-c
-PKG_VERSION:=1.9.1
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@APACHE/avro/avro-$(PKG_VERSION)/c
-PKG_HASH:=7df7bc1e13ce7180f0438ed05ab6642b5b2b6df91f30b927b470e25a78e04642
-
-PKG_MAINTAINER:=John Clark <inindev@gmail.com>
-PKG_LICENSE:=Apache-2.0
-PKG_LICENSE_FILES:=LICENSE
-
-CMAKE_INSTALL:=1
-PKG_BUILD_PARALLEL:=1
-
-include $(INCLUDE_DIR)/package.mk
-include $(INCLUDE_DIR)/cmake.mk
-
-define Package/avro-c
- SECTION:=libs
- CATEGORY:=Libraries
- DEPENDS:=+jansson +zlib +liblzma
- TITLE:=Apache Avro C Library
- URL:=https://avro.apache.org
-endef
-
-define Package/avro-c/description
- This package contains the Apache Avro C library.
-endef
-
-define Package/avro-c-utils
- SECTIONS:=utils
- CATEGORY:=Utilities
- DEPENDS:=+avro-c
- TITLE:=Apache Avro C utilities
- URL:=https://avro.apache.org
-endef
-
-define Package/avro-c-utils/description
- This package contains the Apache Avro C utilities.
-endef
-
-TARGET_LDFLAGS += -Wl,--gc-sections
-
-define Package/avro-c/install
- $(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libavro.so* $(1)/usr/lib/
-endef
-
-define Package/avro-c-utils/install
- $(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/avro* $(1)/usr/bin/
-endef
-
-$(eval $(call BuildPackage,avro-c))
-$(eval $(call BuildPackage,avro-c-utils))
-
diff --git a/libs/avro/patches/010-pkgconfig.patch b/libs/avro/patches/010-pkgconfig.patch
deleted file mode 100644
index 2c95912ec..000000000
--- a/libs/avro/patches/010-pkgconfig.patch
+++ /dev/null
@@ -1,30 +0,0 @@
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -122,9 +122,8 @@ endif(WIN32)
-
- # Install pkg-config file
-
--set(prefix ${CMAKE_INSTALL_PREFIX})
- set(VERSION ${AVRO_VERSION})
--configure_file(avro-c.pc.in avro-c.pc)
-+configure_file(avro-c.pc.in avro-c.pc @ONLY)
- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/avro-c.pc
- DESTINATION lib/pkgconfig)
-
---- a/src/avro-c.pc.in
-+++ b/src/avro-c.pc.in
-@@ -1,7 +1,12 @@
-+prefix=@CMAKE_INSTALL_PREFIX@
-+exec_prefix=@CMAKE_INSTALL_PREFIX@
-+libdir=${exec_prefix}/lib
-+includedir=${prefix}/include
-+
- Name: avro-c
- Description: C library for parsing Avro data
- Version: @VERSION@
- URL: https://avro.apache.org/
--Libs: -L@prefix@/lib -lavro
--Cflags: -I@prefix@/include
-+Libs: -L${libdir} -lavro
-+Cflags: -I${includedir}
- Requires: @CODEC_PKG@
diff --git a/libs/avro/patches/020-bin-shared.patch b/libs/avro/patches/020-bin-shared.patch
deleted file mode 100644
index 61419373d..000000000
--- a/libs/avro/patches/020-bin-shared.patch
+++ /dev/null
@@ -1,27 +0,0 @@
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -129,20 +129,20 @@ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/avro-c.pc
- DESTINATION lib/pkgconfig)
-
- add_executable(avrocat avrocat.c)
--target_link_libraries(avrocat avro-static)
-+target_link_libraries(avrocat avro-shared)
- install(TARGETS avrocat RUNTIME DESTINATION bin)
-
- add_executable(avroappend avroappend.c)
--target_link_libraries(avroappend avro-static)
-+target_link_libraries(avroappend avro-shared)
- install(TARGETS avroappend RUNTIME DESTINATION bin)
-
- if (NOT WIN32)
- #TODO: Port getopt() to Windows to compile avropipe.c and avromod.c
- add_executable(avropipe avropipe.c)
--target_link_libraries(avropipe avro-static)
-+target_link_libraries(avropipe avro-shared)
- install(TARGETS avropipe RUNTIME DESTINATION bin)
-
- add_executable(avromod avromod.c)
--target_link_libraries(avromod avro-static)
-+target_link_libraries(avromod avro-shared)
- install(TARGETS avromod RUNTIME DESTINATION bin)
- endif(NOT WIN32)
diff --git a/libs/avro/patches/030-ssize_t.patch b/libs/avro/patches/030-ssize_t.patch
deleted file mode 100644
index 746c7a5d8..000000000
--- a/libs/avro/patches/030-ssize_t.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/avro_generic_internal.h
-+++ b/src/avro_generic_internal.h
-@@ -28,6 +28,8 @@ extern "C" {
- #include "avro/schema.h"
- #include "avro/value.h"
-
-+#include <stdio.h>
-+
- /*
- * Each generic value implementation struct defines a couple of extra
- * methods that we use to control the lifecycle of the value objects.