aboutsummaryrefslogtreecommitdiff
path: root/libs/avahi
diff options
context:
space:
mode:
authorClaudiu Brasovean <cbrasho@gmail.com>2016-09-28 12:18:41 +0300
committerTed Hess <thess@kitschensync.net>2016-09-28 14:11:53 -0400
commit0312a14a47ca42c6386a570662fd31bfaed7688f (patch)
treefd0d3a5696fd90948ccdf28dc7af6448607a281a /libs/avahi
parent81ce555cf29d5cd0c993cb29c7ba4a28097feccc (diff)
avahi: Update to 0.6.32. Add netifd proto handler for avahi-autoipd
You can now specify in '/etc/config/network' config interface 'eth1_autoip' option ifname 'eth1' option proto 'autoip' And netifd would handle the rest of the logic/setup. Signed-off-by: Claudiu Brasovean <cbrasho@gmail.com> Signed-off-by: Ted Hess <thess@kitschensync.net>
Diffstat (limited to 'libs/avahi')
-rw-r--r--libs/avahi/Makefile12
-rwxr-xr-xlibs/avahi/files/netifd-autoip.sh20
2 files changed, 27 insertions, 5 deletions
diff --git a/libs/avahi/Makefile b/libs/avahi/Makefile
index 2d1a64b31..71e6d62a7 100644
--- a/libs/avahi/Makefile
+++ b/libs/avahi/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2007-2015 OpenWrt.org
+# Copyright (C) 2007-2016 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=avahi
-PKG_VERSION:=0.6.31
-PKG_RELEASE:=12
+PKG_VERSION:=0.6.32
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://avahi.org/download/
-PKG_MD5SUM:=2f22745b8f7368ad5a0a3fddac343f2d
+PKG_SOURCE_URL:=https://github.com/lathiat/avahi/releases/download/v$(PKG_VERSION)
+PKG_MD5SUM:=22b5e705d3eabb31d26f2e1e7b074013
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
PKG_BUILD_DEPENDS:=libexpat libdaemon libgdbm intltool/host libpthread dbus
@@ -357,6 +357,8 @@ define Package/avahi-autoipd/install
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/etc/avahi/avahi-autoipd.action $(1)/etc/avahi/
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/avahi-autoipd $(1)/usr/sbin/
+ $(INSTALL_DIR) $(1)/lib/netifd/proto
+ $(INSTALL_BIN) ./files/netifd-autoip.sh $(1)/lib/netifd/proto/autoip.sh
endef
define Package/avahi-daemon/install
diff --git a/libs/avahi/files/netifd-autoip.sh b/libs/avahi/files/netifd-autoip.sh
new file mode 100755
index 000000000..65f1a8b89
--- /dev/null
+++ b/libs/avahi/files/netifd-autoip.sh
@@ -0,0 +1,20 @@
+#!/bin/sh
+
+. /lib/functions.sh
+. ../netifd-proto.sh
+init_proto "$@"
+
+proto_autoip_setup() {
+ local config="$1"
+ local iface="$2"
+
+ proto_export "INTERFACE=$config"
+ proto_run_command "$config" avahi-autoipd $iface
+}
+
+proto_autoip_teardown() {
+ local interface="$1"
+ proto_kill_command "$interface"
+}
+
+add_protocol autoip