aboutsummaryrefslogtreecommitdiff
path: root/libs/apr-util/Makefile
diff options
context:
space:
mode:
authorSebastian Kemper <sebastian_ml@gmx.net>2020-01-30 21:53:07 +0100
committerSebastian Kemper <sebastian_ml@gmx.net>2020-01-30 21:53:09 +0100
commita16b29480567d89dedc5775d03391e3203d4e644 (patch)
treeec72448d64e1980a28f7400468f6ee8fef5caf91 /libs/apr-util/Makefile
parent430ab5f9b3f1e439e1990dcf3405309fd03a9979 (diff)
apr-util: clean up InstallDev
This removes the ifneq in InstallDev, because the maintainers are likely to forget to extend it when new plugins are added (this has already occurred). Also, this removes the la files, because OpenWrt won't allow them into staging anyway. No rev bump because meaningless for the apr-util packages. Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
Diffstat (limited to 'libs/apr-util/Makefile')
-rw-r--r--libs/apr-util/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/libs/apr-util/Makefile b/libs/apr-util/Makefile
index 2b4f25b55..bd9ba1c98 100644
--- a/libs/apr-util/Makefile
+++ b/libs/apr-util/Makefile
@@ -131,12 +131,10 @@ define Build/InstallDev
$(1)/usr/lib/pkgconfig
$(CP) $(PKG_INSTALL_DIR)/usr/bin/apu-1-config $(1)/usr/bin
$(CP) $(PKG_INSTALL_DIR)/usr/include/apr-1/* $(1)/usr/include/apr-1
-ifneq ($(CONFIG_PACKAGE_libaprutil-crypto-openssl)$(CONFIG_PACKAGE_libaprutil-dbd-pgsql)$(CONFIG_PACKAGE_libaprutil-dbd-sqlite3)$(CONFIG_PACKAGE_libaprutil-ldap),)
$(INSTALL_DIR) $(1)/usr/lib/apr-util-1
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/apr-util-1/apr_*{la,a,so*} \
- $(1)/usr/lib/apr-util-1
-endif
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libaprutil-1.{la,a,so*} \
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/apr-util-1/apr_*.{a,so} \
+ $(1)/usr/lib/apr-util-1 2>/dev/null || :
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libaprutil-1.{a,so*} \
$(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/apr-util-1.pc \
$(1)/usr/lib/pkgconfig