aboutsummaryrefslogtreecommitdiff
path: root/libs/alsa-lib
diff options
context:
space:
mode:
authorMichael Marley <michael@michaelmarley.com>2016-01-19 18:06:32 -0500
committerTed Hess <thess@kitschensync.net>2016-02-01 11:42:41 -0500
commit13b8d4441d8d76cadad6a3ab1367ad332616e48b (patch)
treeba0e388ebe4fb678f902f961b723d8a18e98365c /libs/alsa-lib
parent3bcf5ae450d95d6df91c1fb2411104374e913fa4 (diff)
alsa: Update to 1.1.0, disable basic audio test (bat) utility
Signed-off-by: Ted Hess <thess@kitschensync.net>
Diffstat (limited to 'libs/alsa-lib')
-rw-r--r--libs/alsa-lib/Makefile13
-rw-r--r--libs/alsa-lib/patches/002-remove_cross_compile_guess.patch23
-rw-r--r--libs/alsa-lib/patches/005-fix_include_file_redirect_warnings.patch4
3 files changed, 7 insertions, 33 deletions
diff --git a/libs/alsa-lib/Makefile b/libs/alsa-lib/Makefile
index c4d036e21..a97caf008 100644
--- a/libs/alsa-lib/Makefile
+++ b/libs/alsa-lib/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2015 OpenWrt.org
+# Copyright (C) 2006-2016 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=alsa-lib
-PKG_VERSION:=1.0.29
+PKG_VERSION:=1.1.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=ftp://ftp.alsa-project.org/pub/lib/ \
http://alsa.cybermirror.org/lib/
-PKG_MD5SUM:=de67e0eca72474d6b1121037dafe1024
+PKG_MD5SUM:=69515ca73c3c4a212ef45160dea846c1
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>, \
Peter Wagner <tripolar@gmx.at>
@@ -43,15 +43,12 @@ endef
TARGET_CFLAGS += $(FPIC)
-define Build/Configure
- $(call Build/Configure/Default, \
+CONFIGURE_ARGS+= \
--disable-python \
--disable-debug \
--without-debug \
$(SOFT_FLOAT_CONFIG_OPTION) \
- --with-versioned=no \
- )
-endef
+ --with-versioned=no
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include/
diff --git a/libs/alsa-lib/patches/002-remove_cross_compile_guess.patch b/libs/alsa-lib/patches/002-remove_cross_compile_guess.patch
deleted file mode 100644
index d8f9f122d..000000000
--- a/libs/alsa-lib/patches/002-remove_cross_compile_guess.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -27,20 +27,6 @@ AC_PREFIX_DEFAULT(/usr)
-
- dnl Checks for programs.
-
--dnl try to gues cross-compiler if not set
--if test "x$host" != "x$build" -a -z "`echo $CC | grep -e '-gcc'`";
--then
-- AC_MSG_CHECKING(for cross-compiler)
--
-- which ${program_prefix}gcc >/dev/null 2>&1 && CC=${program_prefix}gcc
-- which ${host_cpu}-${host_os}-gcc >/dev/null 2>&1 \
-- && CC=${host_cpu}-${host_os}-gcc
-- which ${host_cpu}-${host_vendor}-${host_os}-gcc >/dev/null 2>&1 \
-- && CC=${host_cpu}-${host_vendor}-${host_os}-gcc
--
-- AC_MSG_RESULT($CC)
--fi
--
- CFLAGS="$CFLAGS -D_GNU_SOURCE"
-
-
diff --git a/libs/alsa-lib/patches/005-fix_include_file_redirect_warnings.patch b/libs/alsa-lib/patches/005-fix_include_file_redirect_warnings.patch
index 8230c02f5..fc6c6f590 100644
--- a/libs/alsa-lib/patches/005-fix_include_file_redirect_warnings.patch
+++ b/libs/alsa-lib/patches/005-fix_include_file_redirect_warnings.patch
@@ -82,9 +82,9 @@
#include <ctype.h>
-#include <sys/poll.h>
+#include <poll.h>
- #include <sys/shm.h>
#include <sys/mman.h>
#include <limits.h>
+ #include "pcm_local.h"
--- a/src/pcm/pcm_direct.c
+++ b/src/pcm/pcm_direct.c
@@ -30,7 +30,7 @@
@@ -115,9 +115,9 @@
#include <sys/socket.h>
-#include <sys/poll.h>
+#include <poll.h>
- #include <sys/shm.h>
#include <pthread.h>
#include "pcm_local.h"
+
--- a/src/pcm/pcm_shm.c
+++ b/src/pcm/pcm_shm.c
@@ -36,7 +36,7 @@