aboutsummaryrefslogtreecommitdiff
path: root/libs/alsa-lib/Makefile
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-11-19 18:52:05 -0800
committerRosen Penev <rosenp@gmail.com>2020-04-13 22:34:21 -0700
commitd6e2cb105e25ff62cf71acba891b55f273afe018 (patch)
tree115d940442d5ee315668773cc26e3a119825b9ea /libs/alsa-lib/Makefile
parentd917d662aedd9c133217b5c6d8c5a4f4a6bd3dea (diff)
alsa-lib: Update to 1.2.2
Added aserver application. Fixed license information. Small consistency updates. Added usleep patch. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs/alsa-lib/Makefile')
-rw-r--r--libs/alsa-lib/Makefile36
1 files changed, 31 insertions, 5 deletions
diff --git a/libs/alsa-lib/Makefile b/libs/alsa-lib/Makefile
index 4af984ec4..82c4e2b0f 100644
--- a/libs/alsa-lib/Makefile
+++ b/libs/alsa-lib/Makefile
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=alsa-lib
-PKG_VERSION:=1.1.9
+PKG_VERSION:=1.2.2
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=ftp://ftp.alsa-project.org/pub/lib/ \
http://distfiles.gentoo.org/distfiles/
-PKG_HASH:=488373aef5396682f3a411a6d064ae0ad196b9c96269d0bb912fbdeec94b994b
+PKG_HASH:=d8e853d8805574777bbe40937812ad1419c9ea7210e176f0def3e6ed255ab3ec
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>, \
Peter Wagner <tripolar@gmx.at>
@@ -32,7 +32,7 @@ define Package/alsa-lib
TITLE:=ALSA (Advanced Linux Sound Architecture) library
URL:=http://www.alsa-project.org/
DEPENDS:=@AUDIO_SUPPORT +kmod-sound-core +libpthread +librt
- LICENSE:=LGPLv2.1-or-later
+ LICENSE:=LGPL-2.1-or-later
LICENSE_FILES:=COPYING
endef
@@ -41,6 +41,20 @@ define Package/alsa-lib/description
You must have enabled the ALSA support in the kernel.
endef
+define Package/aserver
+ SECTION:=sound
+ CATEGORY:=Sound
+ TITLE:=ALSA (Advanced Linux Sound Architecture) server
+ URL:=http://www.alsa-project.org/
+ DEPENDS:=+alsa-lib
+ LICENSE:=GPL-2.0-or-later
+ LICENSE_FILES:=aserver/COPYING
+endef
+
+define Package/aserver/description
+ This is the aserver application for ALSA.
+endef
+
define Package/alsa-lib/conffiles
/etc/asound.conf
endef
@@ -51,8 +65,8 @@ CONFIGURE_ARGS+= \
--disable-python \
--disable-debug \
--without-debug \
- $(SOFT_FLOAT_CONFIG_OPTION) \
- --with-versioned=no
+ --without-versioned \
+ $(SOFT_FLOAT_CONFIG_OPTION)
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include/
@@ -64,6 +78,9 @@ define Build/InstallDev
$(CP) \
$(PKG_INSTALL_DIR)/usr/lib/libasound.{la,so*} \
$(1)/usr/lib/
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/lib/libatopology.{la,so*} \
+ $(1)/usr/lib/
$(INSTALL_DATA) \
$(PKG_INSTALL_DIR)/usr/lib/pkgconfig/alsa.pc \
$(1)/usr/lib/pkgconfig/
@@ -79,6 +96,9 @@ define Package/alsa-lib/install
$(CP) \
$(PKG_INSTALL_DIR)/usr/lib/libasound.so.* \
$(1)/usr/lib/
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/lib/libatopology.so.* \
+ $(1)/usr/lib/
$(INSTALL_DIR) $(1)/usr/share/alsa/{cards,pcm}
$(INSTALL_DATA) \
@@ -92,4 +112,10 @@ define Package/alsa-lib/install
$(1)/usr/share/alsa/cards/
endef
+define Package/aserver/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/aserver $(1)/usr/bin
+endef
+
$(eval $(call BuildPackage,alsa-lib))
+$(eval $(call BuildPackage,aserver))