aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-07-08 12:59:23 -0700
committerGitHub <noreply@github.com>2019-07-08 12:59:23 -0700
commitfd93e0c817960cb2898785e93a361093eb95abd5 (patch)
tree8e5f17cc02264a5e5600fc87c466473a0a270a31 /lang
parent94c9cc114137ef29a86318619e54bb8cdcf3c0e5 (diff)
parent7950442dffe48139cf9f6e670fd71744004b063a (diff)
Merge pull request #9376 from Cynerd/bigclown-firmware-tool
Bigclown firmware tool
Diffstat (limited to 'lang')
-rw-r--r--lang/python/python-intelhex/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/lang/python/python-intelhex/Makefile b/lang/python/python-intelhex/Makefile
new file mode 100644
index 000000000..4f9619bc1
--- /dev/null
+++ b/lang/python/python-intelhex/Makefile
@@ -0,0 +1,42 @@
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-intelhex
+PKG_VERSION:=2.2.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=intelhex-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/i/intelhex/
+PKG_HASH:=009d8511e0d50639230c39af9607deee771cf026f67ef7507a8c3fd4fa927832
+PKG_BUILD_DIR:=$(BUILD_DIR)/intelhex-$(PKG_VERSION)
+
+PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
+PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILES:=LICENSE.txt
+
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-intelhex
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=python3-intelhex
+ URL:=https://github.com/bialix/intelhex
+ DEPENDS:=+python3-light
+ VARIANT:=python3
+endef
+
+define Package/python3-intelhex/description
+ This work implements an intelhex Python library to read, write, create from
+ scratch and manipulate data from Intel HEX file format.
+endef
+
+PYTHON3_PKG_SETUP_ARGS:=
+
+$(eval $(call Py3Package,python3-intelhex))
+$(eval $(call BuildPackage,python3-intelhex))
+$(eval $(call BuildPackage,python3-intelhex-src))