aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorJavier Marcet <javier@marcet.info>2020-06-08 16:56:33 +0200
committerJavier Marcet <javier@marcet.info>2020-06-08 17:16:36 +0200
commitf04dc3f3aec88929442534fc305cfa813fe3d2cc (patch)
tree799296f87e7095e00a91eb84e2028f2e74e35fbd /lang
parent79873a31e112a303b815c8886e82c92643b6dbbe (diff)
python3-dotenv: add a new package
Signed-off-by: Javier Marcet <javier@marcet.info>
Diffstat (limited to 'lang')
-rw-r--r--lang/python/python-dotenv/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/lang/python/python-dotenv/Makefile b/lang/python/python-dotenv/Makefile
new file mode 100644
index 000000000..1749baf83
--- /dev/null
+++ b/lang/python/python-dotenv/Makefile
@@ -0,0 +1,36 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-dotenv
+PKG_VERSION:=0.13.0
+PKG_RELEASE:=1
+
+PYPI_NAME:=python-dotenv
+PKG_HASH:=3b9909bc96b0edc6b01586e1eed05e71174ef4e04c71da5786370cebea53ad74
+
+PKG_MAINTAINER:=Javier Marcet <javier@marcet.info>
+PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILES:=LICENSE
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-dotenv
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=Add .env support to your django/flask apps in development and deployments
+ URL:=http://github.com/theskumar/python-dotenv
+ DEPENDS:=+python3-light +python3-click
+ VARIANT:=python3
+endef
+
+define Package/python3-dotenv/description
+ A Python library which reads the key-value pair from .env file and adds them
+ to environment variable. It is great for managing app settings during
+ development and in production using 12-factor principles.
+endef
+
+$(eval $(call Py3Package,python3-dotenv))
+$(eval $(call BuildPackage,python3-dotenv))
+$(eval $(call BuildPackage,python3-dotenv-src))