aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorMichael Heimpold <mhei@heimpold.de>2016-09-08 23:02:00 +0200
committerMichael Heimpold <mhei@heimpold.de>2016-09-08 23:07:04 +0200
commite99e704eb439c1ed179acf22971f54a446ff49d9 (patch)
tree593ca40a0bd0ce7c67aeeb41d05185008249eda2 /lang
parentdc5961ffc232ecd7d170287b6d9213aca613590d (diff)
php7-pecl-http: fix build when host has php installed (refs #3149)
When php is installed on the host system, then the configure tries to obtain from this binary whether some extensions are available. This prevents the cross build when the desired extensions are not present - which is the usual case. So add a patch to prevent configure from doing this - we give this information via environment variable during build already. Signed-off-by: Michael Heimpold <mhei@heimpold.de>
Diffstat (limited to 'lang')
-rw-r--r--lang/php7-pecl-http/Makefile2
-rw-r--r--lang/php7-pecl-http/patches/100_config9-m4.patch22
2 files changed, 23 insertions, 1 deletions
diff --git a/lang/php7-pecl-http/Makefile b/lang/php7-pecl-http/Makefile
index 8577006bb..4166d2c5e 100644
--- a/lang/php7-pecl-http/Makefile
+++ b/lang/php7-pecl-http/Makefile
@@ -9,7 +9,7 @@ PECL_NAME:=pecl_http
PECL_LONGNAME:=Extended HTTP Support
PKG_VERSION:=3.0.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_MD5SUM:=042c97314c180f6473338f0c5d35fabd
PKG_NAME:=php7-pecl-http
diff --git a/lang/php7-pecl-http/patches/100_config9-m4.patch b/lang/php7-pecl-http/patches/100_config9-m4.patch
new file mode 100644
index 000000000..304a1dfe8
--- /dev/null
+++ b/lang/php7-pecl-http/patches/100_config9-m4.patch
@@ -0,0 +1,22 @@
+--- a/config9.m4 2016-09-08 21:39:18.000000000 +0200
++++ b/config9.m4 2016-09-08 21:42:35.066903251 +0200
+@@ -71,18 +71,7 @@
+ extname=$1
+ haveext=$[PHP_]translit($1,a-z_-,A-Z__)
+ AC_MSG_CHECKING([for ext/$extname support])
+- if test -x "$PHP_EXECUTABLE"; then
+- grepext=`$PHP_EXECUTABLE -m | $EGREP ^$extname\$`
+- if test "$grepext" = "$extname"; then
+- [PHP_HTTP_HAVE_EXT_]translit($1,a-z_-,A-Z__)=1
+- AC_MSG_RESULT([yes])
+- $2
+- else
+- [PHP_HTTP_HAVE_EXT_]translit($1,a-z_-,A-Z__)=
+- AC_MSG_RESULT([no])
+- $3
+- fi
+- elif test "$haveext" != "no" && test "x$haveext" != "x"; then
++ if test "$haveext" != "no" && test "x$haveext" != "x"; then
+ [PHP_HTTP_HAVE_EXT_]translit($1,a-z_-,A-Z__)=1
+ AC_MSG_RESULT([yes])
+ $2