aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorJavier Marcet <javier@marcet.info>2020-02-17 14:52:40 +0100
committerJavier Marcet <javier@marcet.info>2020-06-08 13:51:04 +0200
commitd69b0091c00f4402354ce6689ba260af6acb15c2 (patch)
tree35c5d5f62fad381eeaf535fb0d63f43760b573dc /lang
parent5ac7f3e9589b9c7fef0893033cf7730cdcc1d626 (diff)
python3-websocket-client: add a new package
Signed-off-by: Javier Marcet <javier@marcet.info>
Diffstat (limited to 'lang')
-rw-r--r--lang/python/python-websocket-client/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/lang/python/python-websocket-client/Makefile b/lang/python/python-websocket-client/Makefile
new file mode 100644
index 000000000..26381f865
--- /dev/null
+++ b/lang/python/python-websocket-client/Makefile
@@ -0,0 +1,37 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-websocket-client
+PKG_VERSION:=0.57.0
+PKG_RELEASE:=1
+
+PYPI_NAME:=websocket_client
+PKG_HASH:=d735b91d6d1692a6a181f2a8c9e0238e5f6373356f561bb9dc4c7af36f452010
+
+PKG_MAINTAINER:=Javier Marcet <javier@marcet.info>
+PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILES:=LICENSE
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-websocket-client
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=WebSocket client for Python. hybi13 is supported
+ URL:=https://github.com/websocket-client/websocket-client
+ DEPENDS:=+python3-light +python3-logging +python3-openssl +python3-six
+ VARIANT:=python3
+endef
+
+define Package/python3-websocket-client/description
+ websocket-client module is WebSocket client for python. This provide the low
+ level APIs for WebSocket. All APIs are the synchronous functions.
+
+ websocket-client supports only hybi-13.
+endef
+
+$(eval $(call Py3Package,python3-websocket-client))
+$(eval $(call BuildPackage,python3-websocket-client))
+$(eval $(call BuildPackage,python3-websocket-client-src))