aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2019-05-05 18:11:40 +0000
committerYousong Zhou <yszhou4tech@gmail.com>2019-05-10 16:49:51 +0800
commitbb7893ed727e30a0876d10521fe56007e41036a7 (patch)
treed3f30a94407c8591a905cf744ec3492eb5ac5c5a /lang
parentac66e2329d2671e6915d70065dc111c255d80b63 (diff)
python-packages: strip quotes around index-url
With pip3.7, `--index-url ""` is different from absence of --index-url argument. Apply the same for python3 variant Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'lang')
-rw-r--r--lang/python/python-packages/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/lang/python/python-packages/Makefile b/lang/python/python-packages/Makefile
index cefc2cb86..1cc565f01 100644
--- a/lang/python/python-packages/Makefile
+++ b/lang/python/python-packages/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=python-packages
PKG_VERSION:=1.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_MAINTAINER:=Yousong Zhou <yszhou4tech@gmail.com>
@@ -66,6 +66,7 @@ CONFIG_PACKAGE_python-packages-list:=$(call qstrip,$(CONFIG_PACKAGE_python-packa
CONFIG_PACKAGE_python-packages-list-cleanup:=$(call qstrip,$(CONFIG_PACKAGE_python-packages-list-cleanup))
CONFIG_PACKAGE_python-packages-envs:=$(call qstrip,$(CONFIG_PACKAGE_python-packages-envs))
CONFIG_PACKAGE_python-packages-extra-deps:=$(call qstrip,$(CONFIG_PACKAGE_python-packages-extra-deps))
+CONFIG_PACKAGE_python-packages-index-url:=$(call qstrip,$(CONFIG_PACKAGE_python-packages-index-url))
CONFIG_PACKAGE_python-packages-pip-opts:=$(call qstrip,$(CONFIG_PACKAGE_python-packages-pip-opts))
HOST_PYTHON_PIP:=$(STAGING_DIR_HOSTPKG)/bin/pip$(PYTHON_VERSION)
@@ -88,7 +89,7 @@ HOST_PYTHON_PIP_INSTALL=$(HOST_PYTHON_PIP) install \
--prefix=$(2) \
--ignore-installed \
--no-compile \
- $(if $(CONFIG_PACKAGE_python-packages-index-url), --index-url $(CONFIG_PACKAGE_python-packages-index-url)) \
+ $(if $(CONFIG_PACKAGE_python-packages-index-url), --index-url "$(CONFIG_PACKAGE_python-packages-index-url)") \
$(if $(CONFIG_PACKAGE_python-packages-pip-opts), $(CONFIG_PACKAGE_python-packages-pip-opts)) \
HOST_PYTHON_PIP_INSTALL_HOST:=$(call HOST_PYTHON_PIP_INSTALL,$(STAGING_DIR_HOSTPKG),"")