aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorPhilip Prindeville <philipp@redfish-solutions.com>2020-04-21 14:17:39 -0600
committerPhilip Prindeville <philipp@redfish-solutions.com>2020-04-21 23:51:03 -0600
commitacf7aef8302987ad1c387cb46e88d7f7a4fd4fd7 (patch)
tree01ccf9d048102f5d12fb3929973b7a3fff5fa6fa /lang
parentccbaf71662066a76e87c0a7066322b85a6d4d20c (diff)
perl: add Net::CIDR::Lite for iptables-mod-geoip
The DBIP geolocation database is generated from sparse data without compaction. Two different ISP's in the same country might have adjacent CIDR blocks, and when aggregated as "country" data, may be merged to conserve space. This package facilitates this. There are scripts to download and preprocess the GeoIP database for iptables-mod-geoip which require this Perl module. Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
Diffstat (limited to 'lang')
-rw-r--r--lang/perl-net-cidr-lite/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/lang/perl-net-cidr-lite/Makefile b/lang/perl-net-cidr-lite/Makefile
new file mode 100644
index 000000000..c09419c84
--- /dev/null
+++ b/lang/perl-net-cidr-lite/Makefile
@@ -0,0 +1,48 @@
+#
+# Copyright (C) 2020 Philip Prindeville, Redfish Solutions, LLC
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=perl-net-cidr-lite
+PKG_VERSION:=0.21
+PKG_RELEASE:=1
+
+PKG_SOURCE:=Net-CIDR-Lite-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://cpan.metacpan.org/authors/id/D/DO/DOUGW
+PKG_HASH:=cfa125e8a2aef9259bc3a44e07cbdfb7894b64d22e7c0cee92aee2f5c7915093
+PKG_BUILD_DIR:=$(BUILD_DIR)/perl/Net-CIDR-Lite-$(PKG_VERSION)
+
+PKG_MAINTAINER:=Philip Prindeville <philipp@redfish-solutions.com>
+PKG_LICENSE:=GPL-1.0-or-later Artistic-1.0-Perl
+
+include $(INCLUDE_DIR)/package.mk
+include ../perl/perlmod.mk
+
+define Package/perl-net-cidr-lite
+ SUBMENU:=Perl
+ SECTION:=lang
+ CATEGORY:=Languages
+ TITLE:=Perl extension for merging IPv4 or IPv6 CIDR addresses
+ URL:=https://search.cpan.org/dist/Net-CIDR-Lite/
+ DEPENDS:=perl +perlbase-essential +perlbase-config +perlbase-io +perlbase-dynaloader
+ PKGARCH:=all
+endef
+
+define Build/Configure
+ $(call perlmod/Configure,,)
+endef
+
+define Build/Compile
+ $(call perlmod/Compile,,)
+endef
+
+define Package/perl-net-cidr-lite/install
+ $(call perlmod/Install,$(1),Net Net/CIDR Net/CIDR/Lite.pm)
+endef
+
+
+$(eval $(call BuildPackage,perl-net-cidr-lite))