aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorPhilip Prindeville <philipp@redfish-solutions.com>2017-10-27 17:17:29 -0600
committerPhilip Prindeville <philipp@redfish-solutions.com>2017-10-27 18:22:13 -0600
commita4aaaf8d8f2eb6d8431f8b1a97ba97380364aa04 (patch)
tree51f469b8d4b52376ea65078c2d64aad035531143 /lang
parent72cb164486f1b67ef26ae84daf3bb3b162644149 (diff)
perl: when Makefile.PL fails give more feedback
There are a few packages which mysteriously fail during the configure stage. Give us better means of understanding why. Also, some Makefile.PL's have "use" statements which reference files which are in or under ".". Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
Diffstat (limited to 'lang')
-rw-r--r--lang/perl/perlmod.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/lang/perl/perlmod.mk b/lang/perl/perlmod.mk
index 7adf16b1b..2ad21e4b5 100644
--- a/lang/perl/perlmod.mk
+++ b/lang/perl/perlmod.mk
@@ -57,7 +57,7 @@ define perlmod/Configure
(cd $(if $(3),$(3),$(PKG_BUILD_DIR)); \
PERL_MM_USE_DEFAULT=1 \
$(2) \
- $(PERL_CMD) -MConfig -e '$$$${tied %Config::Config}{cpprun}="$(GNU_TARGET_NAME)-cpp -E"; do "./Makefile.PL"' \
+ $(PERL_CMD) -MConfig -e '$$$${tied %Config::Config}{cpprun}="$(GNU_TARGET_NAME)-cpp -E"; unshift(@INC, "."); unless (defined (do "./Makefile.PL")) { if ($$$$@) { die "couldn\047t parse Makefile.PL: $$$$@"; } else { die "couldn\047t do Makefile.PL: $$$$!"; } }; die "No Makefile generated!" unless -f "Makefile";' \
$(1) \
AR=ar \
CC=$(GNU_TARGET_NAME)-gcc \