aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorAlexandru Ardelean <ardeleanalex@gmail.com>2019-01-02 20:10:42 +0200
committerAlexandru Ardelean <ardeleanalex@gmail.com>2019-01-02 23:42:01 +0200
commita16dea96274ca85cba19e2afc52530a02e661bd5 (patch)
treeb972b902eba408a4bf8dca980a14de53f0f02b86 /lang
parent582f402907a966594aea2852bd50355aa2406686 (diff)
python,python3: use setuptools & pip versions from python{3}-version.mk
`setuptools` & `pip` whl files were selected via wildcards, because it was easier in the beginning. Also, initially there weren't any PYTHON{3}_{SETUTPTOOLS/PIP}_VERSION variables. But now since these vars exist, it makes sense to use them, because we can catch easier (at build) time if Python/Python3 bump these versions. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Diffstat (limited to 'lang')
-rw-r--r--lang/python/python/Makefile4
-rw-r--r--lang/python/python3/Makefile4
2 files changed, 4 insertions, 4 deletions
diff --git a/lang/python/python/Makefile b/lang/python/python/Makefile
index 639752090..d27882883 100644
--- a/lang/python/python/Makefile
+++ b/lang/python/python/Makefile
@@ -170,7 +170,7 @@ define Build/Compile/python-setuptools
$(STAGING_DIR_HOSTPKG)/bin/pip install \
--ignore-installed \
--root=$(PKG_BUILD_DIR)/install-setuptools --prefix=. \
- $(PKG_BUILD_DIR)/Lib/ensurepip/_bundled/setuptools-*.whl
+ $(PKG_BUILD_DIR)/Lib/ensurepip/_bundled/setuptools-$(PYTHON_SETUPTOOLS_VERSION)-py2.py3-none-any.whl
endef
endif # CONFIG_PACKAGE_python-setuptools
@@ -179,7 +179,7 @@ define Build/Compile/python-pip
$(STAGING_DIR_HOSTPKG)/bin/pip install \
--ignore-installed \
--root=$(PKG_BUILD_DIR)/install-pip --prefix=. \
- $(PKG_BUILD_DIR)/Lib/ensurepip/_bundled/pip-*.whl
+ $(PKG_BUILD_DIR)/Lib/ensurepip/_bundled/pip-$(PYTHON_PIP_VERSION)-py2.py3-none-any.whl
endef
endif # CONFIG_PACKAGE_python-pip
diff --git a/lang/python/python3/Makefile b/lang/python/python3/Makefile
index d6fec695c..e4116e27d 100644
--- a/lang/python/python3/Makefile
+++ b/lang/python/python3/Makefile
@@ -174,7 +174,7 @@ define Build/Compile/python3-setuptools
$(STAGING_DIR_HOSTPKG)/bin/pip3 install \
--ignore-installed \
--root=$(PKG_BUILD_DIR)/install-setuptools --prefix=. \
- $(PKG_BUILD_DIR)/Lib/ensurepip/_bundled/setuptools-*.whl
+ $(PKG_BUILD_DIR)/Lib/ensurepip/_bundled/setuptools-$(PYTHON3_SETUPTOOLS_VERSION)-py2.py3-none-any.whl
endef
endif # CONFIG_PACKAGE_python3-setuptools
@@ -183,7 +183,7 @@ define Build/Compile/python3-pip
$(STAGING_DIR_HOSTPKG)/bin/pip3 install \
--ignore-installed \
--root=$(PKG_BUILD_DIR)/install-pip --prefix=. \
- $(PKG_BUILD_DIR)/Lib/ensurepip/_bundled/pip-*.whl
+ $(PKG_BUILD_DIR)/Lib/ensurepip/_bundled/pip-$(PYTHON3_PIP_VERSION)-py2.py3-none-any.whl
endef
endif # CONFIG_PACKAGE_python3-pip