aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2022-07-07 17:35:41 +0800
committerJeffery To <jeffery.to@gmail.com>2022-07-07 17:35:41 +0800
commit9e3b7d78837b7181b859472894aa243a2eae595b (patch)
tree28706c5808e81e693219d428835ad4cd92a54e55 /lang
parent798cf62bd8bf463f603f6582eb26ac69e154e439 (diff)
python-cryptography: Fix failing build
Fixes https://github.com/openwrt/packages/issues/18876. Fixes https://github.com/openwrt/packages/issues/18879. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang')
-rw-r--r--lang/python/python-cryptography/Makefile2
-rw-r--r--lang/python/python-cryptography/patches/0004-disable-rust.patch7
2 files changed, 6 insertions, 3 deletions
diff --git a/lang/python/python-cryptography/Makefile b/lang/python/python-cryptography/Makefile
index 7284f2a10..f9805d1b3 100644
--- a/lang/python/python-cryptography/Makefile
+++ b/lang/python/python-cryptography/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=python-cryptography
PKG_VERSION:=3.4.8
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PYPI_NAME:=cryptography
PKG_HASH:=94cc5ed4ceaefcbe5bf38c8fba6a21fc1d365bb8fb826ea1688e3370b2e24a1c
diff --git a/lang/python/python-cryptography/patches/0004-disable-rust.patch b/lang/python/python-cryptography/patches/0004-disable-rust.patch
index b005851cb..81c45a44d 100644
--- a/lang/python/python-cryptography/patches/0004-disable-rust.patch
+++ b/lang/python/python-cryptography/patches/0004-disable-rust.patch
@@ -9,9 +9,12 @@
except ImportError:
print(
"""
-@@ -45,7 +45,7 @@ setuptools_rust = "setuptools-rust>=0.11
+@@ -43,9 +43,9 @@ with open(os.path.join(src_dir, "cryptog
+ # `pyproject.toml`
+ setuptools_rust = "setuptools-rust>=0.11.4"
install_requirements = ["cffi>=1.12"]
- setup_requirements = install_requirements + [setuptools_rust]
+-setup_requirements = install_requirements + [setuptools_rust]
++setup_requirements = install_requirements
-if os.environ.get("CRYPTOGRAPHY_DONT_BUILD_RUST"):
+if True: