aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2018-03-18 00:59:09 +0800
committerJeffery To <jeffery.to@gmail.com>2018-06-25 16:52:59 +0800
commit9c6d03db9eca778eaa27026a9d825d66fa20a101 (patch)
tree8073b4a8680eef5b5b54f51e5321f879679d502b /lang
parentde8e819f314213d8cf4043222d9cb084f158642c (diff)
obfs4proxy: new packages (including dependencies)
obfs4proxy is a Tor pluggable transport proxy, implementing obfs4. This commit also includes obfs4proxy's build time dependencies: * golang-github-agl-ed25519: Go implementation of Ed25519 signature algorithm * golang-github-dchest-siphash: Go implementation of SipHash-2-4 * golang-golang-x-crypto: Go supplementary cryptography libraries * golang-golang-x-net: Go supplementary network libraries * golang-golang-x-sys: Go packages for interaction with the OS * golang-golang-x-text: Go text processing support * golang-torproject-pluggable-transports-goptlib: Tor pluggable transports library for Go Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang')
-rw-r--r--lang/golang/golang-github-agl-ed25519/Makefile47
-rw-r--r--lang/golang/golang-github-dchest-siphash/Makefile46
-rw-r--r--lang/golang/golang-golang-x-crypto/Makefile47
-rw-r--r--lang/golang/golang-golang-x-net/Makefile58
-rw-r--r--lang/golang/golang-golang-x-sys/Makefile46
-rw-r--r--lang/golang/golang-golang-x-text/Makefile47
-rw-r--r--lang/golang/golang-torproject-pluggable-transports-goptlib/Makefile45
7 files changed, 336 insertions, 0 deletions
diff --git a/lang/golang/golang-github-agl-ed25519/Makefile b/lang/golang/golang-github-agl-ed25519/Makefile
new file mode 100644
index 000000000..70b500b11
--- /dev/null
+++ b/lang/golang/golang-github-agl-ed25519/Makefile
@@ -0,0 +1,47 @@
+#
+# Copyright (C) 2018 Jeffery To
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=golang-github-agl-ed25519
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://github.com/agl/ed25519.git
+PKG_SOURCE_VERSION:=5312a61534124124185d41f09206b9fef1d88403
+PKG_SOURCE_DATE:=20170117
+PKG_MIRROR_HASH:=be9e9223e7a15f4c12d9f652f5a50a59c01fd1f87ee73bea0ebfd661b5a7ca9c
+
+PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILES:=LICENSE
+PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
+
+PKG_BUILD_DEPENDS:=golang/host
+PKG_BUILD_PARALLEL:=1
+
+GO_PKG:=github.com/agl/ed25519
+GO_PKG_SOURCE_ONLY:=1
+
+include $(INCLUDE_DIR)/package.mk
+include ../golang-package.mk
+
+define Package/golang-github-agl-ed25519-dev
+$(call GoPackage/GoSubMenu)
+ TITLE:=Ed25519 signature algorithm for Go
+ URL:=https://github.com/agl/ed25519
+ DEPENDS:=$(GO_ARCH_DEPENDS) \
+ +golang-golang-x-crypto-dev
+ PKGARCH:=all
+endef
+
+define Package/golang-github-agl-ed25519-dev/description
+Ed25519 is a public-key signature system based on elliptic-curve
+cryptography.
+endef
+
+$(eval $(call GoSrcPackage,golang-github-agl-ed25519-dev))
+$(eval $(call BuildPackage,golang-github-agl-ed25519-dev))
diff --git a/lang/golang/golang-github-dchest-siphash/Makefile b/lang/golang/golang-github-dchest-siphash/Makefile
new file mode 100644
index 000000000..45cd8b71e
--- /dev/null
+++ b/lang/golang/golang-github-dchest-siphash/Makefile
@@ -0,0 +1,46 @@
+#
+# Copyright (C) 2018 Jeffery To
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=golang-github-dchest-siphash
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://github.com/dchest/siphash.git
+PKG_SOURCE_VERSION:=4ebf1de738443ea7f45f02dc394c4df1942a126d
+PKG_SOURCE_DATE:=20160831
+PKG_MIRROR_HASH:=57da99437a6dba8c0b34bb09da48c0b8b1e70391ae0e3563453206794defe051
+
+PKG_LICENSE:=CC0-1.0
+PKG_LICENSE_FILES:=README.md
+PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
+
+PKG_BUILD_DEPENDS:=golang/host
+PKG_BUILD_PARALLEL:=1
+
+GO_PKG:=github.com/dchest/siphash
+GO_PKG_SOURCE_ONLY:=1
+
+include $(INCLUDE_DIR)/package.mk
+include ../golang-package.mk
+
+define Package/golang-github-dchest-siphash-dev
+$(call GoPackage/GoSubMenu)
+ TITLE:=Go implementation of SipHash-2-4
+ URL:=https://github.com/dchest/siphash
+ DEPENDS:=$(GO_ARCH_DEPENDS)
+ PKGARCH:=all
+endef
+
+define Package/golang-github-dchest-siphash-dev/description
+SipHash-2-4 is a pseudorandom function (a.k.a. keyed hash function)
+optimized for speed on short messages.
+endef
+
+$(eval $(call GoSrcPackage,golang-github-dchest-siphash-dev))
+$(eval $(call BuildPackage,golang-github-dchest-siphash-dev))
diff --git a/lang/golang/golang-golang-x-crypto/Makefile b/lang/golang/golang-golang-x-crypto/Makefile
new file mode 100644
index 000000000..e787e04c5
--- /dev/null
+++ b/lang/golang/golang-golang-x-crypto/Makefile
@@ -0,0 +1,47 @@
+#
+# Copyright (C) 2018 Jeffery To
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=golang-golang-x-crypto
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://github.com/golang/crypto.git
+PKG_SOURCE_VERSION:=a49355c7e3f8fe157a85be2f77e6e269a0f89602
+PKG_SOURCE_DATE:=20180620
+PKG_MIRROR_HASH:=80b16b203736ac56883d0610edbc5981eb78f15b7b35d11b5ca639f7c3814214
+
+PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILES:=LICENSE
+PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
+
+PKG_BUILD_DEPENDS:=golang/host
+PKG_BUILD_PARALLEL:=1
+
+GO_PKG:=golang.org/x/crypto
+GO_PKG_SOURCE_ONLY:=1
+
+include $(INCLUDE_DIR)/package.mk
+include ../golang-package.mk
+
+define Package/golang-golang-x-crypto-dev
+$(call GoPackage/GoSubMenu)
+ TITLE:=Go supplementary cryptography libraries
+ URL:=https://godoc.org/golang.org/x/crypto
+ DEPENDS:=$(GO_ARCH_DEPENDS) \
+ +golang-golang-x-net-dev \
+ +golang-golang-x-sys-dev
+ PKGARCH:=all
+endef
+
+define Package/golang-golang-x-crypto-dev/description
+Supplementary Go cryptography libraries.
+endef
+
+$(eval $(call GoSrcPackage,golang-golang-x-crypto-dev))
+$(eval $(call BuildPackage,golang-golang-x-crypto-dev))
diff --git a/lang/golang/golang-golang-x-net/Makefile b/lang/golang/golang-golang-x-net/Makefile
new file mode 100644
index 000000000..979d9be7f
--- /dev/null
+++ b/lang/golang/golang-golang-x-net/Makefile
@@ -0,0 +1,58 @@
+#
+# Copyright (C) 2018 Jeffery To
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=golang-golang-x-net
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://github.com/golang/net.git
+PKG_SOURCE_VERSION:=afe8f62b1d6bbd81f31868121a50b06d8188e1f9
+PKG_SOURCE_DATE:=20180620
+PKG_MIRROR_HASH:=9a8bb3bf21ea60121d7e87f1bd1af9effbdcd908f758be99457653172d13eb1e
+
+PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILES:=LICENSE
+PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
+
+PKG_BUILD_DEPENDS:=golang/host
+PKG_BUILD_PARALLEL:=1
+
+GO_PKG:=golang.org/x/net
+# exclude http2/h2i to break circular dependency with golang-golang-x-crypto-dev
+# since there are no other binaries, can skip compilation
+GO_PKG_SOURCE_ONLY:=1
+
+include $(INCLUDE_DIR)/package.mk
+include ../golang-package.mk
+
+define Package/golang-golang-x-net-dev
+$(call GoPackage/GoSubMenu)
+ TITLE:=Go supplementary network libraries
+ URL:=https://godoc.org/golang.org/x/net
+ DEPENDS:=$(GO_ARCH_DEPENDS) +golang-golang-x-text-dev
+ PKGARCH:=all
+endef
+
+define Package/golang-golang-x-net-dev/description
+Supplementary Go networking libraries.
+endef
+
+# http2/testdata/draft-ietf-httpbis-http2.xml is a non-free document
+# http2/z_spec_test.go uses http2/testdata/draft-ietf-httpbis-http2.xml
+define Package/golang-golang-x-net-dev/install
+ $(call GoPackage/Package/Install/Src,$(1))
+
+ rm -f $(1)$(GO_PKG_PATH)/src/$(GO_PKG)/http2/testdata/draft-ietf-httpbis-http2.xml
+ rmdir $(1)$(GO_PKG_PATH)/src/$(GO_PKG)/http2/testdata/
+
+ rm -f $(1)$(GO_PKG_PATH)/src/$(GO_PKG)/http2/z_spec_test.go
+endef
+
+$(eval $(call GoSrcPackage,golang-golang-x-net-dev))
+$(eval $(call BuildPackage,golang-golang-x-net-dev))
diff --git a/lang/golang/golang-golang-x-sys/Makefile b/lang/golang/golang-golang-x-sys/Makefile
new file mode 100644
index 000000000..5350f3cbe
--- /dev/null
+++ b/lang/golang/golang-golang-x-sys/Makefile
@@ -0,0 +1,46 @@
+#
+# Copyright (C) 2018 Jeffery To
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=golang-golang-x-sys
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://github.com/golang/sys.git
+PKG_SOURCE_VERSION:=63fc586f45fe72d95d5240a5d5eb95e6503907d3
+PKG_SOURCE_DATE:=20180621
+PKG_MIRROR_HASH:=3afe7936fb9fb291ef9b9cfa88f51576cdc19abbd34240232ce284958ac7dbaf
+
+PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILES:=LICENSE
+PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
+
+PKG_BUILD_DEPENDS:=golang/host
+PKG_BUILD_PARALLEL:=1
+
+GO_PKG:=golang.org/x/sys
+GO_PKG_SOURCE_ONLY:=1
+
+include $(INCLUDE_DIR)/package.mk
+include ../golang-package.mk
+
+define Package/golang-golang-x-sys-dev
+$(call GoPackage/GoSubMenu)
+ TITLE:=Go packages for interaction with the OS
+ URL:=https://godoc.org/golang.org/x/sys
+ DEPENDS:=$(GO_ARCH_DEPENDS)
+ PKGARCH:=all
+endef
+
+define Package/golang-golang-x-sys-dev/description
+Supplementary Go packages for low-level interactions with the operating
+system.
+endef
+
+$(eval $(call GoSrcPackage,golang-golang-x-sys-dev))
+$(eval $(call BuildPackage,golang-golang-x-sys-dev))
diff --git a/lang/golang/golang-golang-x-text/Makefile b/lang/golang/golang-golang-x-text/Makefile
new file mode 100644
index 000000000..e3b1120b9
--- /dev/null
+++ b/lang/golang/golang-golang-x-text/Makefile
@@ -0,0 +1,47 @@
+#
+# Copyright (C) 2018 Jeffery To
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=golang-golang-x-text
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://github.com/golang/text.git
+PKG_SOURCE_VERSION:=5cec4b58c438bd98288aeb248bab2c1840713d21
+PKG_SOURCE_DATE:=20180520
+PKG_MIRROR_HASH:=6c541a59f32f57afa54a2216045ddf16a077f8fe2e823fbbe77723eca04ddddb
+
+PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILES:=LICENSE
+PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
+
+PKG_BUILD_DEPENDS:=golang/host
+PKG_BUILD_PARALLEL:=1
+
+GO_PKG:=golang.org/x/text
+# exclude gotext (and message/pipeline) to avoid dependency on golang.org/x/tools
+# since there are no other binaries, can skip compilation
+GO_PKG_SOURCE_ONLY:=1
+
+include $(INCLUDE_DIR)/package.mk
+include ../golang-package.mk
+
+define Package/golang-golang-x-text-dev
+$(call GoPackage/GoSubMenu)
+ TITLE:=Go text processing support
+ URL:=https://godoc.org/golang.org/x/text
+ DEPENDS:=$(GO_ARCH_DEPENDS)
+ PKGARCH:=all
+endef
+
+define Package/golang-golang-x-text-dev/description
+Supplementary Go libraries for text processing, many involving Unicode.
+endef
+
+$(eval $(call GoSrcPackage,golang-golang-x-text-dev))
+$(eval $(call BuildPackage,golang-golang-x-text-dev))
diff --git a/lang/golang/golang-torproject-pluggable-transports-goptlib/Makefile b/lang/golang/golang-torproject-pluggable-transports-goptlib/Makefile
new file mode 100644
index 000000000..6457408bb
--- /dev/null
+++ b/lang/golang/golang-torproject-pluggable-transports-goptlib/Makefile
@@ -0,0 +1,45 @@
+#
+# Copyright (C) 2018 Jeffery To
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=golang-torproject-pluggable-transports-goptlib
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://git.torproject.org/pluggable-transports/goptlib.git
+PKG_SOURCE_VERSION:=7d56ec4f381e8b1aedfda360594e35a5731b5337
+PKG_SOURCE_DATE:=20180320
+PKG_MIRROR_HASH:=ec28d8882e031046efd561764e1b9119376844a1c3d4941e038cfbe32e60b058
+
+PKG_LICENSE:=CC0-1.0
+PKG_LICENSE_FILES:=COPYING
+PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
+
+PKG_BUILD_DEPENDS:=golang/host
+PKG_BUILD_PARALLEL:=1
+
+GO_PKG:=git.torproject.org/pluggable-transports/goptlib.git
+GO_PKG_SOURCE_ONLY:=1
+
+include $(INCLUDE_DIR)/package.mk
+include ../golang-package.mk
+
+define Package/golang-torproject-pluggable-transports-goptlib-dev
+$(call GoPackage/GoSubMenu)
+ TITLE:=Tor pluggable transports library for Go
+ URL:=https://gitweb.torproject.org/pluggable-transports/goptlib.git/
+ DEPENDS:=$(GO_ARCH_DEPENDS)
+ PKGARCH:=all
+endef
+
+define Package/golang-torproject-pluggable-transports-goptlib-dev/description
+goptlib is a library for writing Tor pluggable transports in Go.
+endef
+
+$(eval $(call GoSrcPackage,golang-torproject-pluggable-transports-goptlib-dev))
+$(eval $(call BuildPackage,golang-torproject-pluggable-transports-goptlib-dev))