aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2017-02-17 10:03:04 +0200
committerGitHub <noreply@github.com>2017-02-17 10:03:04 +0200
commit9c176d0b353b0aa1ea14f2084daf72fed0ad127a (patch)
tree63071fa9c7d59ec230e147f4c7674ca78ef58986 /lang
parent9d8487851e01736b2d5ba9f13a05a8a0cf98284b (diff)
parenta5b9cc6a24581a68dcb3b6a053b71f8ae83ee530 (diff)
Merge pull request #3860 from commodo/micropython-lib-workaround
micropython-lib: workaround the `install` build rule
Diffstat (limited to 'lang')
1 files changed, 2 insertions, 3 deletions
diff --git a/lang/micropython-lib/Makefile b/lang/micropython-lib/Makefile
index 2f3fc6180..989506ae9 100644
--- a/lang/micropython-lib/Makefile
+++ b/lang/micropython-lib/Makefile
@@ -42,13 +42,12 @@ define Package/micropython-lib/description
endef
MAKE_FLAGS:=\
- -C $(PKG_BUILD_DIR) \
- PREFIX=$(PKG_BUILD_DIR)/_install_tmp \
+ PREFIX=$(PKG_BUILD_DIR)/_install_tmp/dist \
install
define Package/micropython-lib/install
$(INSTALL_DIR) $(1)/usr/lib/micropython
- $(CP) $(PKG_BUILD_DIR)/_install_tmp/* $(1)/usr/lib/micropython
+ $(CP) $(PKG_BUILD_DIR)/_install_tmp/dist/* $(1)/usr/lib/micropython
endef
$(eval $(call BuildPackage,micropython-lib))