aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-08-29 12:10:08 +0800
committerTianling Shen <cnsztl@gmail.com>2023-09-04 14:34:24 +0800
commit98453732e2b7f74234776445844609f3b4dc70d0 (patch)
treef5062cda51d63f66b11bc17066bab633d0fdce3e /lang
parent3684df0dc356a9c5b1e7c51cc43e203c7254c8e5 (diff)
python-websockets: Update to 11.0.3, update list of dependencies
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang')
-rw-r--r--lang/python/python-websockets/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/lang/python/python-websockets/Makefile b/lang/python/python-websockets/Makefile
index 737ea39f4..fac0d741b 100644
--- a/lang/python/python-websockets/Makefile
+++ b/lang/python/python-websockets/Makefile
@@ -8,11 +8,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=python-websockets
-PKG_VERSION:=10.3
+PKG_VERSION:=11.0.3
PKG_RELEASE:=1
PYPI_NAME:=websockets
-PKG_HASH:=fc06cc8073c8e87072138ba1e431300e2d408f054b27047d047b549455066ff4
+PKG_HASH:=88fc51d9a26b10fc331be344f1781224a375b78488fc343620184e95a4b27016
PKG_MAINTAINER:=Michal Vasilek <michal.vasilek@nic.cz>
PKG_LICENSE:=BSD-3-Clause
@@ -26,18 +26,18 @@ define Package/python3-websockets
SECTION:=lang
CATEGORY:=Languages
SUBMENU:=Python
- TITLE:=Library for developing WebSocket servers and clients
- URL:=https://websockets.readthedocs.io/
- DEPENDS:=+python3-light +python3-asyncio +python3-ctypes +python3-email \
- +python3-logging +python3-urllib
+ TITLE:=Implementation of the WebSocket Protocol
+ URL:=https://github.com/aaugustin/websockets
+ DEPENDS:=+python3
endef
define Package/python3-websockets/description
- websockets is a library for building WebSocket servers and clients
- in Python with a focus on correctness and simplicity.
+websockets is a library for building WebSocket servers and clients in
+Python with a focus on correctness, simplicity, robustness, and
+performance.
- Built on top of asyncio, Python’s standard asynchronous I/O framework.
- It provides an elegant coroutine-based API.
+Built on top of asyncio, Python's standard asynchronous I/O framework,
+the default implementation provides an elegant coroutine-based API.
endef
$(eval $(call Py3Package,python3-websockets))