aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorMichael Heimpold <mhei@heimpold.de>2019-01-11 23:47:30 +0100
committerMichael Heimpold <mhei@heimpold.de>2019-01-11 23:51:47 +0100
commit963c841463cee3a2d8afc34b5363a3e097556e04 (patch)
tree637b8dbed0d8c6dbc93b9ce38fe4a48dbeb7478d /lang
parent1fadeeaedd99a0900568bc72a0482cc9ee03bc1f (diff)
php7: update to 7.2.14
While at, add --with-pic to configure arguments. This prevents the following build errors spotted by the build bots for i386 targets: -snip- ... ext/openssl/.libs/openssl.o: direct GOT relocation R_386_GOT32X against `X509_REQ_free' without base register can not be used when making a shared object ... -snap- This parameter seems to make no difference on other targets, nor improve or make worse the package size. Run tested for i386 in VirtualBox VM and on Duckbill for mxs platform. Signed-off-by: Michael Heimpold <mhei@heimpold.de>
Diffstat (limited to 'lang')
-rw-r--r--lang/php7/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/lang/php7/Makefile b/lang/php7/Makefile
index 149941793..a36dfbb1f 100644
--- a/lang/php7/Makefile
+++ b/lang/php7/Makefile
@@ -6,7 +6,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=php
-PKG_VERSION:=7.2.13
+PKG_VERSION:=7.2.14
PKG_RELEASE:=1
PKG_MAINTAINER:=Michael Heimpold <mhei@heimpold.de>
@@ -16,7 +16,7 @@ PKG_LICENSE_FILES:=LICENSE
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=http://www.php.net/distributions/
-PKG_HASH:=14b0429abdb46b65c843e5882c9a8c46b31dfbf279c747293b8ab950c2644a4b
+PKG_HASH:=ee3f1cc102b073578a3c53ba4420a76da3d9f0c981c02b1664ae741ca65af84f
PKG_FIXUP:=libtool autoreconf
PKG_BUILD_PARALLEL:=1
@@ -175,6 +175,7 @@ CONFIGURE_ARGS+= \
--enable-fpm \
--enable-shared \
--disable-static \
+ --with-pic \
--disable-rpath \
--disable-debug \
--disable-phpdbg \