aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorJavier Marcet <javier@marcet.info>2020-06-12 11:57:42 +0200
committerJavier Marcet <javier@marcet.info>2020-06-12 11:57:42 +0200
commit94dbeabaabc0ecccb81602d46a5dd7ec36de9451 (patch)
treee0ec819826205eef19fd7cb62cd440b830fc3f75 /lang
parentcc75765cdea82c8303c96164353b36f3b8a4e233 (diff)
docker-compose: fix depends after merge in master and move to utils
Signed-off-by: Javier Marcet <javier@marcet.info>
Diffstat (limited to 'lang')
-rw-r--r--lang/python/docker-compose/Makefile55
-rw-r--r--lang/python/python-distro/Makefile4
-rw-r--r--lang/python/python-dockerpty/Makefile4
-rw-r--r--lang/python/python-dotenv/Makefile4
-rw-r--r--lang/python/python-jsonschema/Makefile7
5 files changed, 11 insertions, 63 deletions
diff --git a/lang/python/docker-compose/Makefile b/lang/python/docker-compose/Makefile
deleted file mode 100644
index aa8d206e9..000000000
--- a/lang/python/docker-compose/Makefile
+++ /dev/null
@@ -1,55 +0,0 @@
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=docker-compose
-PKG_VERSION:=1.26.0
-PKG_RELEASE:=1
-
-PYPI_NAME:=docker-compose
-PKG_HASH:=7e836102d139aca667d6af53f0f4d942c9459ec24d6dd4f0203d74359b0fd311
-
-PKG_MAINTAINER:=Javier Marcet <javier@marcet.info>
-PKG_LICENSE:=Apache-2.0
-PKG_LICENSE_FILES:=LICENSE
-
-include ../pypi.mk
-include $(INCLUDE_DIR)/package.mk
-include ../python3-package.mk
-
-PKG_USE_MIPS16:=0
-
-PYTHON3_PKG_SETUP_ARGS:=
-
-define Package/docker-compose
- SECTION:=lang
- CATEGORY:=Languages
- SUBMENU:=Python
- TITLE:=Docker Compose
- URL:=https://github.com/docker/compose
- DEPENDS+=+docker-ce \
- +python3 \
- +python3-cached-property \
- +python3-colorama \
- +python3-distro \
- +python3-distutils \
- +python3-docopt \
- +python3-docker \
- +python3-dockerpty \
- +python3-dotenv \
- +python3-jsonschema \
- +python3-pkg-resources \
- +python3-requests \
- +python3-setuptools \
- +python3-six \
- +python3-texttable \
- +python3-websocket-client \
- +python3-yaml
- VARIANT:=python3
-endef
-
-define Package/docker-compose/description
- Multi-container orchestration for Docker
-endef
-
-$(eval $(call Py3Package,docker-compose))
-$(eval $(call BuildPackage,docker-compose))
-$(eval $(call BuildPackage,docker-compose-src))
diff --git a/lang/python/python-distro/Makefile b/lang/python/python-distro/Makefile
index e33dc8e66..26c9befe8 100644
--- a/lang/python/python-distro/Makefile
+++ b/lang/python/python-distro/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=python-distro
PKG_VERSION:=1.5.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PYPI_NAME:=distro
PKG_HASH:=0e58756ae38fbd8fc3020d54badb8eae17c5b9dcbed388b17bb55b8a5928df92
@@ -21,7 +21,7 @@ define Package/python3-distro
SUBMENU:=Python
TITLE:=Distro - an OS platform information API
URL:=https://github.com/nir0s/distro
- DEPENDS:=+python3-light
+ DEPENDS:=+python3-light +python3-logging
VARIANT:=python3
endef
diff --git a/lang/python/python-dockerpty/Makefile b/lang/python/python-dockerpty/Makefile
index 642572749..f27143425 100644
--- a/lang/python/python-dockerpty/Makefile
+++ b/lang/python/python-dockerpty/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=python-dockerpty
PKG_VERSION:=0.4.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PYPI_NAME:=dockerpty
PKG_HASH:=69a9d69d573a0daa31bcd1c0774eeed5c15c295fe719c61aca550ed1393156ce
@@ -23,7 +23,7 @@ define Package/python3-dockerpty
SUBMENU:=Python
TITLE:=Python library to use the pseudo-tty of a docker container
URL:=https://github.com/d11wtq/dockerpty
- DEPENDS:=+python3-light +python3-docker +python3-six
+ DEPENDS:=+python3-light +python3-openssl +python3-six
VARIANT:=python3
endef
diff --git a/lang/python/python-dotenv/Makefile b/lang/python/python-dotenv/Makefile
index 1749baf83..0075c1281 100644
--- a/lang/python/python-dotenv/Makefile
+++ b/lang/python/python-dotenv/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=python-dotenv
PKG_VERSION:=0.13.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PYPI_NAME:=python-dotenv
PKG_HASH:=3b9909bc96b0edc6b01586e1eed05e71174ef4e04c71da5786370cebea53ad74
@@ -21,7 +21,7 @@ define Package/python3-dotenv
SUBMENU:=Python
TITLE:=Add .env support to your django/flask apps in development and deployments
URL:=http://github.com/theskumar/python-dotenv
- DEPENDS:=+python3-light +python3-click
+ DEPENDS:=+python3-light +python3-logging
VARIANT:=python3
endef
diff --git a/lang/python/python-jsonschema/Makefile b/lang/python/python-jsonschema/Makefile
index 9f8551c97..a47b3e909 100644
--- a/lang/python/python-jsonschema/Makefile
+++ b/lang/python/python-jsonschema/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=python-jsonschema
PKG_VERSION:=3.2.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PYPI_NAME:=jsonschema
PKG_HASH:=c8a85b28d377cc7737e46e2d9f2b4f44ee3c0e1deac6bf46ddefc7187d30797a
@@ -11,6 +11,8 @@ PKG_MAINTAINER:=Javier Marcet <javier@marcet.info>
PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=COPYING
+HOST_PYTHON3_PACKAGE_BUILD_DEPENDS=setuptools_scm
+
include ../pypi.mk
include $(INCLUDE_DIR)/package.mk
include ../python3-package.mk
@@ -21,7 +23,8 @@ define Package/python3-jsonschema
SUBMENU:=Python
TITLE:=An implementation of JSON Schema validation
URL:=https://github.com/Julian/jsonschema
- DEPENDS:=+python3-light +python3-attrs +python3-six +python3-pyrsistent
+ DEPENDS:=+python3-light +python3-attrs +python3-urllib \
+ +python3-six +python3-pyrsistent +python3-setuptools
VARIANT:=python3
endef