aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-01-26 14:47:25 -0800
committerGitHub <noreply@github.com>2020-01-26 14:47:25 -0800
commit934886fff7aeb753569d498f35b68580f5c45c1f (patch)
tree60b4035fd64a2d6eb1e70bd4243745cc1326dd3f /lang
parent1631e5ae379bc804185d2c41eedeaed584d449be (diff)
parent6f8912099f907745924bd8780a803b623a3f8e50 (diff)
Merge pull request #11097 from jempatel/python3-speedtest-cli
python3-speedtest-cli: a new package
Diffstat (limited to 'lang')
1 files changed, 35 insertions, 0 deletions
diff --git a/lang/python/python3-speedtest-cli/Makefile b/lang/python/python3-speedtest-cli/Makefile
new file mode 100644
index 000000000..ec5311647
--- /dev/null
+++ b/lang/python/python3-speedtest-cli/Makefile
@@ -0,0 +1,35 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python3-speedtest-cli
+PKG_VERSION:=2.1.2
+PKG_RELEASE:=1
+
+PYPI_NAME:=speedtest-cli
+PKG_HASH:=cf1d386222f94c324e3125ba9a0d187e46d4a13dca08c023bdb9a23096be2e54
+
+PKG_MAINTAINER:=Jaymin Patel <jem.patel@gmail.com>
+PKG_LICENSE:=Apache-2.0
+PKG_LICENSE_FILES:=LICENSE
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-speedtest-cli
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=Command line interface for testing internet bandwidth using speedtest.net
+ URL:=https://github.com/sivel/speedtest-cli
+ DEPENDS:=+python3-light +python3-pkg-resources +python3-xml +python3-email \
+ +python3-urllib +python3-codecs +python3-openssl
+ VARIANT:=python3
+endef
+
+define Package/python3-speedtest-cli/description
+ Command line interface for testing internet bandwidth using speedtest.net
+endef
+
+$(eval $(call Py3Package,python3-speedtest-cli))
+$(eval $(call BuildPackage,python3-speedtest-cli))
+$(eval $(call BuildPackage,python3-speedtest-cli-src))