aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorEneas U de Queiroz <cote2004-github@yahoo.com>2019-05-16 11:53:36 -0300
committerEneas U de Queiroz <cote2004-github@yahoo.com>2019-05-17 23:10:40 -0300
commit8b03ed31248b43a653926de3e25f657408b2e515 (patch)
tree911f42c3d1743942ed8b28d54652357931e083b1 /lang
parent37ebbb545eea22078cdc5758fcc00d738691e6a0 (diff)
python-qrcode: adjust Makefile style
Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
Diffstat (limited to 'lang')
-rw-r--r--lang/python/python-qrcode/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/lang/python/python-qrcode/Makefile b/lang/python/python-qrcode/Makefile
index a39febfb0..54d333ce1 100644
--- a/lang/python/python-qrcode/Makefile
+++ b/lang/python/python-qrcode/Makefile
@@ -1,6 +1,4 @@
#
-# Copyright (C) 2007-2016 OpenWrt.org
-#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
@@ -10,22 +8,26 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=python-qrcode
PKG_VERSION:=6.1
PKG_RELEASE:=1
+
+PKG_MAINTAINER:=Eneas U de Queiroz <cote2004-github@yahoo.com>
PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILES:=LICENSE
PKG_SOURCE:=qrcode-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/q/qrcode/
PKG_HASH:=505253854f607f2abf4d16092c61d4e9d511a3b4392e60bff957a68592b04369
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-oauthlib-$(PKG_VERSION)
-PKG_UNPACK=$(HOST_TAR) -C $(PKG_BUILD_DIR) --strip-components=1 -xzf $(DL_DIR)/$(PKG_SOURCE)
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-qrcode-$(PKG_VERSION)
include $(INCLUDE_DIR)/package.mk
include ../python-package.mk
+PKG_UNPACK:=$(HOST_TAR) -C $(PKG_BUILD_DIR) --strip-components=1 -xzf $(DL_DIR)/$(PKG_SOURCE)
+
define Package/python-qrcode
SUBMENU:=Python
SECTION:=lang
CATEGORY:=Languages
- MAINTAINER:=Eneas U de Queiroz <cote2004-github@yahoo.com>
TITLE:=QR Code image generator
URL:=https://github.com/lincolnloop/python-qrcode
DEPENDS:=+python +python-six +python-setuptools +pillow