aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2020-04-09 23:02:14 +0800
committerJeffery To <jeffery.to@gmail.com>2020-04-19 01:56:11 +0800
commit87b8f45230c59d2b4c90ee0a2caaa5a22bf3d77a (patch)
treed63f18a61db7b40c830d30f13b6d9da8c03f38f8 /lang
parent3642b18441a386e0af2b5912b2d823f7b4dd7939 (diff)
python3: Rename canned recipes in python3-host.mk
This changes the recipe name prefix from Build/Compile/HostPy3 to HostPython3, and clarifies some of the names (RunHost to Run, Mod to ModSetup). Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang')
-rw-r--r--lang/python/python-six/Makefile2
-rw-r--r--lang/python/python3-host.mk10
-rw-r--r--lang/python/python3-package.mk2
-rw-r--r--lang/python/python3-packages/Makefile2
4 files changed, 8 insertions, 8 deletions
diff --git a/lang/python/python-six/Makefile b/lang/python/python-six/Makefile
index 3f0250d26..70c90a91a 100644
--- a/lang/python/python-six/Makefile
+++ b/lang/python/python-six/Makefile
@@ -49,7 +49,7 @@ documentation for more information on what is provided.
endef
define Host/Compile
- $(call Build/Compile/HostPy3Mod,,install --prefix="" --root="$(STAGING_DIR_HOSTPKG)")
+ $(call HostPython3/ModSetup,,install --prefix="" --root="$(STAGING_DIR_HOSTPKG)")
endef
Host/Install:=
diff --git a/lang/python/python3-host.mk b/lang/python/python3-host.mk
index e8a375d13..81b0025b1 100644
--- a/lang/python/python3-host.mk
+++ b/lang/python/python3-host.mk
@@ -5,7 +5,7 @@
# See /LICENSE for more information.
#
-# Note: include this after `include $(TOPDIR)/rules.mk in your package Makefile
+# Note: include this file after `include $(TOPDIR)/rules.mk in your package Makefile
# if `python3-package.mk` is included, this will already be included
# For PYTHON3_VERSION
@@ -40,7 +40,7 @@ HOST_PYTHON3_VARS = \
# $(1) => directory of python script
# $(2) => python script and its arguments
# $(3) => additional variables
-define Build/Compile/HostPy3RunHost
+define HostPython3/Run
cd "$(if $(strip $(1)),$(strip $(1)),.)" && \
$(HOST_PYTHON3_VARS) \
$(3) \
@@ -51,7 +51,7 @@ endef
HOST_PYTHON3_PIP:=$(STAGING_DIR_HOSTPKG)/bin/pip$(PYTHON3_VERSION)
# $(1) => packages to install
-define Build/Compile/HostPy3PipInstall
+define HostPython3/PipInstall
$(HOST_PYTHON3_VARS) \
$(HOST_PYTHON3_PIP) \
--disable-pip-version-check \
@@ -63,8 +63,8 @@ endef
# $(1) => build subdir
# $(2) => additional arguments to setup.py
# $(3) => additional variables
-define Build/Compile/HostPy3Mod
- $(call Build/Compile/HostPy3RunHost, \
+define HostPython3/ModSetup
+ $(call HostPython3/Run, \
$(HOST_BUILD_DIR)/$(strip $(1)), \
setup.py $(2), \
$(3))
diff --git a/lang/python/python3-package.mk b/lang/python/python3-package.mk
index 0571bb271..88ab726eb 100644
--- a/lang/python/python3-package.mk
+++ b/lang/python/python3-package.mk
@@ -142,7 +142,7 @@ PYTHON3_PKG_SETUP_VARS ?=
define Py3Build/Compile/Default
$(if $(HOST_PYTHON3_PACKAGE_BUILD_DEPENDS),
- $(call Build/Compile/HostPy3PipInstall,$(HOST_PYTHON3_PACKAGE_BUILD_DEPENDS))
+ $(call HostPython3/PipInstall,$(HOST_PYTHON3_PACKAGE_BUILD_DEPENDS))
)
$(call Build/Compile/Py3Mod, \
$(PYTHON3_PKG_SETUP_DIR), \
diff --git a/lang/python/python3-packages/Makefile b/lang/python/python3-packages/Makefile
index e3c8f6225..4310fe920 100644
--- a/lang/python/python3-packages/Makefile
+++ b/lang/python/python3-packages/Makefile
@@ -101,7 +101,7 @@ HOST_PYTHON3_PIP_INSTALL_CLEANUP:=$(call HOST_PYTHON3_PIP_INSTALL,$(PKG_INSTALL_
define Build/Compile
$(foreach pkg,$(CONFIG_PACKAGE_python3-packages-list-host),
- $(call Build/Compile/HostPy3RunHost,,$(HOST_PYTHON3_PIP_INSTALL_HOST) $(pkg))
+ $(call HostPython3/Run,,$(HOST_PYTHON3_PIP_INSTALL_HOST) $(pkg))
)
$(foreach pkg,$(CONFIG_PACKAGE_python3-packages-list),
$(call Build/Compile/HostPy3RunTarget,,$(call HOST_PYTHON3_PIP_INSTALL_TARGET,$(pkg)) $(pkg),$(CONFIG_PACKAGE_python3-packages-envs))