aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorAlexandru Ardelean <ardeleanalex@gmail.com>2017-11-06 18:05:14 +0200
committerAlexandru Ardelean <ardeleanalex@gmail.com>2017-11-06 18:06:02 +0200
commit8750a59d3d6e89b18d327d084b649927301e244b (patch)
tree5121e50384f7636f061b69adfa40ca573c872414 /lang
parent007c7a142860f0542b7edeb1ff3c226e6a10ae84 (diff)
python,python3: apply PKG_FIXUP:=autoreconf
Should hopefully provide more consistent results across distros. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Diffstat (limited to 'lang')
-rw-r--r--lang/python/python/Makefile3
-rw-r--r--lang/python/python3/Makefile1
2 files changed, 3 insertions, 1 deletions
diff --git a/lang/python/python/Makefile b/lang/python/python/Makefile
index 03cda5ce9..232f4bffc 100644
--- a/lang/python/python/Makefile
+++ b/lang/python/python/Makefile
@@ -14,7 +14,7 @@ PKG_NAME:=python
PKG_VERSION:=$(PYTHON_VERSION).$(PYTHON_VERSION_MICRO)
# XXX: reset PKG_RELEASE to 1 only if Python's pip & setuptools versions have also bumped;
# otherwise, keep bumping PKG_RELEASE
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://www.python.org/ftp/python/$(PKG_VERSION)
@@ -29,6 +29,7 @@ include ./files/python-host.mk
# For PyPackage
include ./files/python-package.mk
+PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1
HOST_BUILD_PARALLEL:=1
diff --git a/lang/python/python3/Makefile b/lang/python/python3/Makefile
index 01f89981c..9253c9688 100644
--- a/lang/python/python3/Makefile
+++ b/lang/python/python3/Makefile
@@ -32,6 +32,7 @@ include ./files/python3-host.mk
# For Py3Package
include ./files/python3-package.mk
+PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1
HOST_BUILD_PARALLEL:=1