aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorJosef Schlehofer <pepe.schlehofer@gmail.com>2019-04-01 02:50:10 +0200
committerGitHub <noreply@github.com>2019-04-01 02:50:10 +0200
commit7f5e18f0d9838e0fdf46a3c48146b5010fe93c4d (patch)
tree25b5f8db4f082c5ed72b8a04851a5d9748b27ab5 /lang
parente924f1be7fe52e50e58dfc2120b543eaf9599d44 (diff)
parent76874c1f62dadeeeed09436afb08e85ba21a4c4d (diff)
Merge pull request #8526 from BKPepe/voluptuous-serialize
python-voluptuous-serialize: add package for Python3
Diffstat (limited to 'lang')
-rw-r--r--lang/python/python-voluptuous-serialize/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/lang/python/python-voluptuous-serialize/Makefile b/lang/python/python-voluptuous-serialize/Makefile
new file mode 100644
index 000000000..401ed25a3
--- /dev/null
+++ b/lang/python/python-voluptuous-serialize/Makefile
@@ -0,0 +1,41 @@
+#
+# Copyright (C) 2019 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=voluptuous-serialize
+PKG_VERSION:=2.1.0
+PKG_RELEASE:=1
+
+PKG_SOURCE:=voluptuous-serialize-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/v/voluptuous-serialize/
+PKG_HASH:=d30fef4f1aba251414ec0b315df81a06da7bf35201dcfb1f6db5253d738a154f
+
+PKG_MAINTAINER:=Josef Schlehofer <josef.schlehofer@nic.cz>
+PKG_LICENSE:=Apache-2.0
+PKG_LICENSE_FILES:=COPYING
+
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-voluptuous-serialize
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=Python Voluptuous Serialize
+ URL:=https://github.com/balloob/voluptuous-serialize
+ DEPENDS:=+python3-light
+ VARIANT:=python3
+endef
+
+define Package/python3-voluptuous-serialize/description
+Convert Voluptuous schemas to dictionaries so they can be serialized.
+endef
+
+$(eval $(call Py3Package,python3-voluptuous-serialize))
+$(eval $(call BuildPackage,python3-voluptuous-serialize))
+$(eval $(call BuildPackage,python3-voluptuous-serialize-src))