aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorBreuss Simon <simon.breuss@gmail.com>2016-11-21 19:10:04 +0100
committerBreuss Simon <simon.breuss@gmail.com>2016-11-21 20:07:32 +0100
commit7e1b756cd30d88dcee9c45972f31b023e2bddbab (patch)
tree3aa7206dd1bd41906a93d3acb038878465d1018c /lang
parentb543186c7c2d22b9233fc78942cd2e9a896d4cde (diff)
update micropython and micropython-lib to v1.8.6
Signed-off-by: Breuss Simon <simon.breuss@gmail.com>
Diffstat (limited to 'lang')
3 files changed, 25 insertions, 7 deletions
diff --git a/lang/micropython-lib/Makefile b/lang/micropython-lib/Makefile
index 6c99f3f3e..2f3fc6180 100644
--- a/lang/micropython-lib/Makefile
+++ b/lang/micropython-lib/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=micropython-lib
-PKG_VERSION=0.5-20151122-$(PKG_SOURCE_VERSION)
+PKG_VERSION=1.8.6-$(PKG_SOURCE_VERSION)
PKG_RELEASE:=1
PKG_MAINTAINER:=Roger D <rogerdammit@gmail.com>
@@ -17,7 +17,7 @@ PKG_LICENSE_FILES:=LICENSE
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/micropython/micropython-lib.git
-PKG_SOURCE_VERSION:=9643541e6e89b96cb9785a618b19865f8c0f7215
+PKG_SOURCE_VERSION:=f81e979c56dddb771ad36ec381b7f2c6cd12111f
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION)
PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
diff --git a/lang/micropython/Makefile b/lang/micropython/Makefile
index 83806167c..7ee58827d 100644
--- a/lang/micropython/Makefile
+++ b/lang/micropython/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=micropython
-PKG_VERSION=1.5-20151122-$(PKG_SOURCE_VERSION)
+PKG_VERSION=1.8.6-$(PKG_SOURCE_VERSION)
PKG_RELEASE:=1
PKG_MAINTAINER:=Roger D <rogerdammit@gmail.com>
@@ -17,7 +17,7 @@ PKG_LICENSE_FILES:=LICENSE
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/micropython/micropython.git
-PKG_SOURCE_VERSION:=4120f32292090bd811165fe76780e4e74e3450b9
+PKG_SOURCE_VERSION:=5a1d63fc14dae788f705403a43c2d8639b7dd9cd
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
@@ -40,9 +40,14 @@ define Package/micropython/description
that is optimised to run on a microcontroller (and low power computers).
endef
-MAKE_FLAGS += \
- -C $(PKG_BUILD_DIR)/unix \
- MICROPY_USE_READLINE=0
+
+MAKE_FLAGS += -C $(PKG_BUILD_DIR)/unix
+
+define Build/Compile
+ $(call Build/Compile/Default,axtls)
+ $(call Build/Compile/Default)
+
+endef
define Package/micropython/install
$(INSTALL_DIR) $(1)/usr/bin
diff --git a/lang/micropython/patches/000-Makefile-no-errors b/lang/micropython/patches/000-Makefile-no-errors
new file mode 100644
index 000000000..765f3e701
--- /dev/null
+++ b/lang/micropython/patches/000-Makefile-no-errors
@@ -0,0 +1,13 @@
+Index: micropython-1.5-20161117-e81a5353cb794b8d6c57317488e5db6a1c524755/unix/Makefile
+===================================================================
+--- micropython-1.5-20161117-e81a5353cb794b8d6c57317488e5db6a1c524755.orig/unix/Makefile 2016-11-17 02:43:13.000000000 +0100
++++ micropython-1.5-20161117-e81a5353cb794b8d6c57317488e5db6a1c524755/unix/Makefile 2016-11-17 16:49:02.937809018 +0100
+@@ -21,7 +21,7 @@
+ INC += -I$(BUILD)
+
+ # compiler settings
+-CWARN = -Wall -Werror
++CWARN = -Wall
+ CWARN += -Wpointer-arith -Wuninitialized
+ CFLAGS = $(INC) $(CWARN) -ansi -std=gnu99 -DUNIX $(CFLAGS_MOD) $(COPT) $(CFLAGS_EXTRA)
+