aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorAlexandru Ardelean <ardeleanalex@gmail.com>2016-11-07 09:46:47 +0200
committerAlexandru Ardelean <ardeleanalex@gmail.com>2016-11-07 10:55:33 +0200
commit7d89234b86df46b4a11fbf35fba8e5102396b539 (patch)
treec516b88f520c49c45c3a3ea37290c27a26d7dc56 /lang
parente81632ab90c63237eab0acb092a226ea1367b3cb (diff)
python,python3: get rid of HOST_CFLAGS
They rely on system paths and are a bit misleading/confusing. As seen here: https://github.com/openwrt/packages/issues/3339 Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Diffstat (limited to 'lang')
2 files changed, 0 insertions, 8 deletions
diff --git a/lang/python/Makefile b/lang/python/Makefile
index 687481fab..3235b4557 100644
--- a/lang/python/Makefile
+++ b/lang/python/Makefile
@@ -220,10 +220,6 @@ define PyPackage/python/filespec
-|$(PYTHON_PKG_DIR)
endef
-HOST_CFLAGS+= \
- -I/usr/include/ncursesw \
- -I/usr/include/ncurses
-
HOST_CONFIGURE_ARGS+= \
--without-cxx-main \
--without-pymalloc \
diff --git a/lang/python3/Makefile b/lang/python3/Makefile
index 2d177ab3a..c46f3bd56 100644
--- a/lang/python3/Makefile
+++ b/lang/python3/Makefile
@@ -208,10 +208,6 @@ define Py3Package/python3/filespec
-|$(PYTHON3_PKG_DIR)
endef
-HOST_CFLAGS+= \
- -I/usr/include/ncursesw \
- -I/usr/include/ncurses
-
HOST_CONFIGURE_ARGS+= \
--without-cxx-main \
--without-pymalloc \