aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-11-04 09:26:57 -0800
committerGitHub <noreply@github.com>2019-11-04 09:26:57 -0800
commit75f958e3ce9f56700c764bd38e21e84ff6e0286f (patch)
treee108c970f5f027fcc4eabfd2151bffd6db1603dc /lang
parente239dba4005860de4f1c8930c0d337a2910ee2f0 (diff)
parent0c8b0b0bf727a57b0138a1425d2f32786dddd146 (diff)
Merge pull request #10453 from commodo/python3-fix-build
python3: fix build on Ubuntu/Debian multi-arch
Diffstat (limited to 'lang')
-rw-r--r--lang/python/python3/Makefile2
-rw-r--r--lang/python/python3/patches/006-do-not-add-multiarch-paths-when-cross-compiling.patch12
2 files changed, 13 insertions, 1 deletions
diff --git a/lang/python/python3/Makefile b/lang/python/python3/Makefile
index cfa1c00c0..809cda4d0 100644
--- a/lang/python/python3/Makefile
+++ b/lang/python/python3/Makefile
@@ -14,7 +14,7 @@ PYTHON_VERSION:=$(PYTHON3_VERSION)
PYTHON_VERSION_MICRO:=$(PYTHON3_VERSION_MICRO)
PKG_NAME:=python3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_VERSION:=$(PYTHON_VERSION).$(PYTHON_VERSION_MICRO)
PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
diff --git a/lang/python/python3/patches/006-do-not-add-multiarch-paths-when-cross-compiling.patch b/lang/python/python3/patches/006-do-not-add-multiarch-paths-when-cross-compiling.patch
new file mode 100644
index 000000000..16ef86ab8
--- /dev/null
+++ b/lang/python/python3/patches/006-do-not-add-multiarch-paths-when-cross-compiling.patch
@@ -0,0 +1,12 @@
+--- a/setup.py
++++ b/setup.py
+@@ -654,7 +654,8 @@ class PyBuildExt(build_ext):
+ # only change this for cross builds for 3.3, issues on Mageia
+ if CROSS_COMPILING:
+ self.add_cross_compiling_paths()
+- self.add_multiarch_paths()
++ else:
++ self.add_multiarch_paths()
+ self.add_ldflags_cppflags()
+
+ def init_inc_lib_dirs(self):