aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorMarcel Denia <naoir@gmx.net>2014-07-05 11:06:51 +0200
committerMarcel Denia <naoir@gmx.net>2014-07-07 22:54:16 +0200
commit7534bea1979017d410b537ab06a3c1581449840d (patch)
treed25156f87794356d82975225146187f3f6bcecaf /lang
parent980773283e0c2796427af4e7e9005beb8b94c1d5 (diff)
lang/perl: Fixup formatting
Signed-off-by: Marcel Denia <naoir@gmx.net>
Diffstat (limited to 'lang')
-rw-r--r--lang/perl/Makefile11
-rw-r--r--lang/perl/files/Module/ScanDeps.pm4
-rw-r--r--lang/perl/files/strippm.sh2
3 files changed, 8 insertions, 9 deletions
diff --git a/lang/perl/Makefile b/lang/perl/Makefile
index a562b0c04..935a1abdb 100644
--- a/lang/perl/Makefile
+++ b/lang/perl/Makefile
@@ -45,7 +45,7 @@ $(call Package/perl/Default)
endef
define Package/microperl/description
- A perl package without operating-specific functions such as readdir.
+ A perl package without operating-specific functions such as readdir.
endef
define Build/Template
@@ -87,9 +87,9 @@ $(call Package/perl/Default)
endef
define Package/perl/description
- Perl is a stable, cross platform programming language.
- It is used for mission critical projects in the public and private sectors
- and is widely used to program web applications of all needs.
+ Perl is a stable, cross platform programming language.
+ It is used for mission critical projects in the public and private sectors
+ and is widely used to program web applications of all needs.
endef
define Build/perl/Configure
@@ -140,10 +140,9 @@ define Build/perl/Compile
# been generated if we weren't cross compiling
echo -e 'miniperl.target:\n\t$$$$(CC) $$$$(CLDFLAGS) -o miniperl.target $$$$(mini_obj) $$$$(libs)' >> $(PKG_BUILD_DIR)/Makefile
+$(MAKE) $(MAKE_J) -C $(PKG_BUILD_DIR) miniperl.target
-
mkdir -p $(PKG_BUILD_DIR)/target-bin
install -m 0755 $(PKG_BUILD_DIR)/miniperl.target $(PKG_BUILD_DIR)/target-bin/miniperl
-
+
@echo
@echo "===> Stage 5: Build target perl binary"
@echo
diff --git a/lang/perl/files/Module/ScanDeps.pm b/lang/perl/files/Module/ScanDeps.pm
index 4f3a7d55b..0493be11b 100644
--- a/lang/perl/files/Module/ScanDeps.pm
+++ b/lang/perl/files/Module/ScanDeps.pm
@@ -14,7 +14,7 @@ use base 'Exporter';
use constant dl_ext => ".$Config{dlext}";
use constant lib_ext => $Config{lib_ext};
use constant is_insensitive_fs => (
- -s $0
+ -s $0
and (-s lc($0) || -1) == (-s uc($0) || -1)
and (-s lc($0) || -1) == -s $0
);
@@ -342,7 +342,7 @@ my %Preload = (
) {
return $_ if _find_in_inc($_);
}
-
+
for (
"$archlib/pods/perldiag.pod",
"$privlib/pods/perldiag-$Config{version}.pod",
diff --git a/lang/perl/files/strippm.sh b/lang/perl/files/strippm.sh
index b83d2b461..48622e523 100644
--- a/lang/perl/files/strippm.sh
+++ b/lang/perl/files/strippm.sh
@@ -1,5 +1,5 @@
#!/bin/sh
-#
+#
# Attempt to strip comments and pod docs from perl modules
#