aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2022-01-11 17:52:47 +0800
committerRosen Penev <rosenp@gmail.com>2022-01-11 16:24:13 -0800
commit6754a2c80a0cab7aadae12d7444463f0c5318e29 (patch)
tree5d0521f8ffff7fe7f832d8ecace2095a6f5fc416 /lang
parentb9d10fc3e675acd8074e8b93737d3f1dcf74654b (diff)
micropython-lib: Update to latest master
The last tagged release (v1.9.3) was in 2017. This updates the package to the most recent commit of the master branch. This also sets myself at the maintainer. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang')
-rw-r--r--lang/python/micropython-lib/Makefile44
1 files changed, 23 insertions, 21 deletions
diff --git a/lang/python/micropython-lib/Makefile b/lang/python/micropython-lib/Makefile
index 4e02a73e1..c1d42aedd 100644
--- a/lang/python/micropython-lib/Makefile
+++ b/lang/python/micropython-lib/Makefile
@@ -8,15 +8,16 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=micropython-lib
-PKG_VERSION:=1.9.3
PKG_RELEASE:=1
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://codeload.github.com/micropython/micropython-lib/tar.gz/v$(PKG_VERSION)?
-PKG_HASH:=66e15380eb109613263beb6825b8eecb9191088270c1a59e8c7d922dd57183c7
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://github.com/micropython/micropython-lib.git
+PKG_SOURCE_VERSION:=cdd260f0792d04a1ded99171b4c7a2582b7856b4
+PKG_SOURCE_DATE:=20211112
+PKG_MIRROR_HASH:=fea11185756e746e78cfe66dc4fa33830721cd94d726ac7cf4dde2e0a16d5041
-PKG_MAINTAINER:=Roger D <rogerdammit@gmail.com>
-PKG_LICENSE:=MIT, PSFL
+PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
+PKG_LICENSE:=MIT PSF-2.0
PKG_LICENSE_FILES:=LICENSE
PKG_BUILD_PARALLEL:=1
@@ -24,28 +25,29 @@ PKG_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/package.mk
define Package/micropython-lib
- SUBMENU:=Python
- SECTION:=lang
- CATEGORY:=Languages
- TITLE:=micropython-lib
- URL:=https://github.com/micropython/micropython-lib
- DEPENDS:=+micropython
+ SUBMENU:=Python
+ SECTION:=lang
+ CATEGORY:=Languages
+ TITLE:=micropython-lib
+ URL:=https://github.com/micropython/micropython-lib
+ DEPENDS:=+micropython
endef
define Package/micropython-lib/description
- This package contains micropython-lib, a project to develop a non-monolothic
- standard library for Micro Python. Note that this is a work in progress and
- several libraries may be missing, incomplete or buggy.
+ This is a repository of libraries designed to be useful for writing
+ MicroPython applications.
endef
-MAKE_FLAGS:=\
- PREFIX=$(PKG_BUILD_DIR)/_install_tmp/dist \
- install
+Build/Compile:=:
define Package/micropython-lib/install
- $(INSTALL_DIR) $(1)/usr/lib/micropython
- $(CP) $(PKG_BUILD_DIR)/_install_tmp/dist/* $(1)/usr/lib/micropython
+ for dir in micropython python-ecosys python-stdlib unix-ffi; do \
+ $(INSTALL_DIR) $(1)/usr/lib/micropython/$$$$dir ; \
+ $(CP) $(PKG_BUILD_DIR)/$$$$dir/* $(1)/usr/lib/micropython/$$$$dir/ ; \
+ done
+ $(FIND) $(1)/usr/lib/micropython \
+ -not -type d \( -not -name '*.py' -o -name 'test_*' -o -name 'setup.py' \) -delete
+ $(FIND) $(1)/usr/lib/micropython -mindepth 1 -empty -type d -delete
endef
$(eval $(call BuildPackage,micropython-lib))
-