aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2018-07-12 15:12:03 +0300
committerGitHub <noreply@github.com>2018-07-12 15:12:03 +0300
commit666602f7f73364304749db780a559eb39c659176 (patch)
tree4d5395b792be550eb9556d9a69aad506f46fa5c5 /lang
parent3ec9fc2f5da3bb29cd173f93ad1525c35cda8a47 (diff)
parent2080550f766ea415b737829479de9554e8ef7f9f (diff)
Merge pull request #6411 from crza/update-python
python3: update to python 3.7.0
Diffstat (limited to 'lang')
-rw-r--r--lang/python/python3-version.mk6
-rw-r--r--lang/python/python3/Makefile2
-rw-r--r--lang/python/python3/files/config.site1
-rw-r--r--lang/python/python3/patches/001-enable-zlib.patch2
-rw-r--r--lang/python/python3/patches/003-do-not-run-distutils-tests.patch6
-rw-r--r--lang/python/python3/patches/004-do-not-write-bytes-codes.patch10
-rw-r--r--lang/python/python3/patches/006-remove-multi-arch-and-local-paths.patch4
-rw-r--r--lang/python/python3/patches/010-do-not-add-rt-lib-dirs-when-cross-compiling.patch2
-rw-r--r--lang/python/python3/patches/012-add-support-source-date-epoch-pyc.patch13
-rw-r--r--lang/python/python3/patches/013-getbuildinfo-date-time-source-date-epoch.patch4
-rw-r--r--lang/python/python3/patches/014-remove-platform-so-suffix.patch4
-rw-r--r--lang/python/python3/patches/015-abort-on-failed-modules.patch2
-rw-r--r--lang/python/python3/patches/016-adjust-config-paths.patch10
13 files changed, 27 insertions, 39 deletions
diff --git a/lang/python/python3-version.mk b/lang/python/python3-version.mk
index dd6c947ac..8f4cf1ebb 100644
--- a/lang/python/python3-version.mk
+++ b/lang/python/python3-version.mk
@@ -7,8 +7,8 @@
# Note: keep in sync with setuptools & pip
PYTHON3_VERSION_MAJOR:=3
-PYTHON3_VERSION_MINOR:=6
-PYTHON3_VERSION_MICRO:=5
+PYTHON3_VERSION_MINOR:=7
+PYTHON3_VERSION_MICRO:=0
PYTHON3_VERSION:=$(PYTHON3_VERSION_MAJOR).$(PYTHON3_VERSION_MINOR)
@@ -16,7 +16,7 @@ PYTHON3_SETUPTOOLS_PKG_RELEASE:=1
PYTHON3_PIP_PKG_RELEASE:=1
PYTHON3_SETUPTOOLS_VERSION:=39.0.1
-PYTHON3_PIP_VERSION:=9.0.3
+PYTHON3_PIP_VERSION:=10.0.1
PYTHON3_SETUPTOOLS_VERSION:=$(PYTHON3_SETUPTOOLS_VERSION)-$(PYTHON3_SETUPTOOLS_PKG_RELEASE)
PYTHON3_PIP_VERSION:=$(PYTHON3_PIP_VERSION)-$(PYTHON3_PIP_PKG_RELEASE)
diff --git a/lang/python/python3/Makefile b/lang/python/python3/Makefile
index 9f1886094..e0a72a766 100644
--- a/lang/python/python3/Makefile
+++ b/lang/python/python3/Makefile
@@ -19,7 +19,7 @@ PKG_VERSION:=$(PYTHON_VERSION).$(PYTHON_VERSION_MICRO)
PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://www.python.org/ftp/python/$(PKG_VERSION)
-PKG_HASH:=f434053ba1b5c8a5cc597e966ead3c5143012af827fd3f0697d21450bb8d87a6
+PKG_HASH:=0382996d1ee6aafe59763426cf0139ffebe36984474d0ec4126dd1c40a8b3549
PKG_LICENSE:=PSF
PKG_LICENSE_FILES:=LICENSE Modules/_ctypes/libffi_msvc/LICENSE Modules/_ctypes/darwin/LICENSE Modules/_ctypes/libffi/LICENSE Modules/_ctypes/libffi_osx/LICENSE Tools/pybench/LICENSE
diff --git a/lang/python/python3/files/config.site b/lang/python/python3/files/config.site
index cfa56b89b..65c2d9585 100644
--- a/lang/python/python3/files/config.site
+++ b/lang/python/python3/files/config.site
@@ -9,4 +9,5 @@
ac_cv_file__dev_ptmx=yes
ac_cv_file__dev_ptc=no
ac_cv_buggy_getaddrinfo=no
+ac_cv_header_uuid_h=yes
diff --git a/lang/python/python3/patches/001-enable-zlib.patch b/lang/python/python3/patches/001-enable-zlib.patch
index 1a2a68ebf..4ea3f54ad 100644
--- a/lang/python/python3/patches/001-enable-zlib.patch
+++ b/lang/python/python3/patches/001-enable-zlib.patch
@@ -9,7 +9,7 @@ Subject: [PATCH] enable zlib
--- a/Modules/Setup.dist
+++ b/Modules/Setup.dist
-@@ -363,7 +363,7 @@ _symtable symtablemodule.c
+@@ -335,7 +335,7 @@ _symtable symtablemodule.c
# Andrew Kuchling's zlib module.
# This require zlib 1.1.3 (or later).
# See http://www.gzip.org/zlib/
diff --git a/lang/python/python3/patches/003-do-not-run-distutils-tests.patch b/lang/python/python3/patches/003-do-not-run-distutils-tests.patch
index 599385980..bfcd8d62e 100644
--- a/lang/python/python3/patches/003-do-not-run-distutils-tests.patch
+++ b/lang/python/python3/patches/003-do-not-run-distutils-tests.patch
@@ -1,6 +1,6 @@
--- a/Makefile.pre.in
+++ b/Makefile.pre.in
-@@ -1341,6 +1341,7 @@ libinstall: build_all $(srcdir)/Modules/
+@@ -1381,6 +1381,7 @@ libinstall: build_all $(srcdir)/Modules/
$(INSTALL_DATA) `cat pybuilddir.txt`/_sysconfigdata_$(ABIFLAGS)_$(MACHDEP)_$(MULTIARCH).py \
$(DESTDIR)$(LIBDEST); \
$(INSTALL_DATA) $(srcdir)/LICENSE $(DESTDIR)$(LIBDEST)/LICENSE.txt
@@ -8,11 +8,11 @@
if test -d $(DESTDIR)$(LIBDEST)/distutils/tests; then \
$(INSTALL_DATA) $(srcdir)/Modules/xxmodule.c \
$(DESTDIR)$(LIBDEST)/distutils/tests ; \
-@@ -1376,6 +1377,7 @@ libinstall: build_all $(srcdir)/Modules/
+@@ -1416,6 +1417,7 @@ libinstall: build_all $(srcdir)/Modules/
$(PYTHON_FOR_BUILD) -m lib2to3.pgen2.driver $(DESTDIR)$(LIBDEST)/lib2to3/Grammar.txt
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
$(PYTHON_FOR_BUILD) -m lib2to3.pgen2.driver $(DESTDIR)$(LIBDEST)/lib2to3/PatternGrammar.txt
+endif
python-config: $(srcdir)/Misc/python-config.in Misc/python-config.sh
- # Substitution happens here, as the completely-expanded BINDIR
+ @ # Substitution happens here, as the completely-expanded BINDIR
diff --git a/lang/python/python3/patches/004-do-not-write-bytes-codes.patch b/lang/python/python3/patches/004-do-not-write-bytes-codes.patch
index 463263222..eb66443aa 100644
--- a/lang/python/python3/patches/004-do-not-write-bytes-codes.patch
+++ b/lang/python/python3/patches/004-do-not-write-bytes-codes.patch
@@ -1,10 +1,10 @@
--- a/Python/pylifecycle.c
+++ b/Python/pylifecycle.c
-@@ -88,7 +88,7 @@ int Py_BytesWarningFlag; /* Warn on str(
- int Py_UseClassExceptionsFlag = 1; /* Needed by bltinmodule.c: deprecated */
- int Py_FrozenFlag; /* Needed by getpath.c */
- int Py_IgnoreEnvironmentFlag; /* e.g. PYTHONPATH, PYTHONHOME */
--int Py_DontWriteBytecodeFlag; /* Suppress writing bytecode files (*.pyc) */
+@@ -120,7 +120,7 @@ int Py_NoSiteFlag = 0; /* Suppress 'impo
+ int Py_BytesWarningFlag = 0; /* Warn on str(bytes) and str(buffer) */
+ int Py_FrozenFlag = 0; /* Needed by getpath.c */
+ int Py_IgnoreEnvironmentFlag = 0; /* e.g. PYTHONPATH, PYTHONHOME */
+-int Py_DontWriteBytecodeFlag = 0; /* Suppress writing bytecode files (*.pyc) */
+int Py_DontWriteBytecodeFlag = 1; /* Suppress writing bytecode files (*.pyc) */
int Py_NoUserSiteDirectory = 0; /* for -s and site.py */
int Py_UnbufferedStdioFlag = 0; /* Unbuffered binary std{in,out,err} */
diff --git a/lang/python/python3/patches/006-remove-multi-arch-and-local-paths.patch b/lang/python/python3/patches/006-remove-multi-arch-and-local-paths.patch
index cad73edc8..57fc9bc38 100644
--- a/lang/python/python3/patches/006-remove-multi-arch-and-local-paths.patch
+++ b/lang/python/python3/patches/006-remove-multi-arch-and-local-paths.patch
@@ -1,7 +1,7 @@
--- a/setup.py
+++ b/setup.py
-@@ -512,16 +512,9 @@ class PyBuildExt(build_ext):
- return ['m']
+@@ -537,16 +537,9 @@ class PyBuildExt(build_ext):
+ os.unlink(tmpfile)
def detect_modules(self):
- # Ensure that /usr/local is always used, but the local build
diff --git a/lang/python/python3/patches/010-do-not-add-rt-lib-dirs-when-cross-compiling.patch b/lang/python/python3/patches/010-do-not-add-rt-lib-dirs-when-cross-compiling.patch
index 3211f7386..be5fcb940 100644
--- a/lang/python/python3/patches/010-do-not-add-rt-lib-dirs-when-cross-compiling.patch
+++ b/lang/python/python3/patches/010-do-not-add-rt-lib-dirs-when-cross-compiling.patch
@@ -1,6 +1,6 @@
--- a/setup.py
+++ b/setup.py
-@@ -522,8 +522,9 @@ class PyBuildExt(build_ext):
+@@ -547,8 +547,9 @@ class PyBuildExt(build_ext):
# directly since an inconsistently reproducible issue comes up where
# the environment variable is not set even though the value were passed
# into configure and stored in the Makefile (issue found on OS X 10.3).
diff --git a/lang/python/python3/patches/012-add-support-source-date-epoch-pyc.patch b/lang/python/python3/patches/012-add-support-source-date-epoch-pyc.patch
deleted file mode 100644
index 4c2c2f7cd..000000000
--- a/lang/python/python3/patches/012-add-support-source-date-epoch-pyc.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/Lib/py_compile.py
-+++ b/Lib/py_compile.py
-@@ -137,8 +137,9 @@ def compile(file, cfile=None, dfile=None
- except FileExistsError:
- pass
- source_stats = loader.path_stats(file)
-+ mtime = int(os.getenv('SOURCE_DATE_EPOCH', source_stats['mtime']))
- bytecode = importlib._bootstrap_external._code_to_bytecode(
-- code, source_stats['mtime'], source_stats['size'])
-+ code, mtime, source_stats['size'])
- mode = importlib._bootstrap_external._calc_mode(file)
- importlib._bootstrap_external._write_atomic(cfile, bytecode, mode)
- return cfile
diff --git a/lang/python/python3/patches/013-getbuildinfo-date-time-source-date-epoch.patch b/lang/python/python3/patches/013-getbuildinfo-date-time-source-date-epoch.patch
index 340e302d8..a3bdb3345 100644
--- a/lang/python/python3/patches/013-getbuildinfo-date-time-source-date-epoch.patch
+++ b/lang/python/python3/patches/013-getbuildinfo-date-time-source-date-epoch.patch
@@ -1,6 +1,6 @@
--- a/Makefile.pre.in
+++ b/Makefile.pre.in
-@@ -725,6 +725,16 @@ regen-all: regen-opcode regen-opcode-tar
+@@ -743,6 +743,16 @@ regen-all: regen-opcode regen-opcode-tar
############################################################################
# Special rules for object files
@@ -17,7 +17,7 @@
Modules/getbuildinfo.o: $(PARSER_OBJS) \
$(OBJECT_OBJS) \
$(PYTHON_OBJS) \
-@@ -732,6 +742,8 @@ Modules/getbuildinfo.o: $(PARSER_OBJS) \
+@@ -750,6 +760,8 @@ Modules/getbuildinfo.o: $(PARSER_OBJS) \
$(MODOBJS) \
$(srcdir)/Modules/getbuildinfo.c
$(CC) -c $(PY_CORE_CFLAGS) \
diff --git a/lang/python/python3/patches/014-remove-platform-so-suffix.patch b/lang/python/python3/patches/014-remove-platform-so-suffix.patch
index c209fa745..de7badd99 100644
--- a/lang/python/python3/patches/014-remove-platform-so-suffix.patch
+++ b/lang/python/python3/patches/014-remove-platform-so-suffix.patch
@@ -1,6 +1,6 @@
--- a/configure
+++ b/configure
-@@ -14995,7 +14995,7 @@ $as_echo_n "checking ABIFLAGS... " >&6;
+@@ -14962,7 +14962,7 @@ $as_echo_n "checking ABIFLAGS... " >&6;
$as_echo "$ABIFLAGS" >&6; }
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking SOABI" >&5
$as_echo_n "checking SOABI... " >&6; }
@@ -11,7 +11,7 @@
--- a/configure.ac
+++ b/configure.ac
-@@ -4647,7 +4647,7 @@ AC_SUBST(SOABI)
+@@ -4665,7 +4665,7 @@ AC_SUBST(SOABI)
AC_MSG_CHECKING(ABIFLAGS)
AC_MSG_RESULT($ABIFLAGS)
AC_MSG_CHECKING(SOABI)
diff --git a/lang/python/python3/patches/015-abort-on-failed-modules.patch b/lang/python/python3/patches/015-abort-on-failed-modules.patch
index 09a48af69..9d7579418 100644
--- a/lang/python/python3/patches/015-abort-on-failed-modules.patch
+++ b/lang/python/python3/patches/015-abort-on-failed-modules.patch
@@ -1,6 +1,6 @@
--- a/setup.py
+++ b/setup.py
-@@ -333,6 +333,7 @@ class PyBuildExt(build_ext):
+@@ -354,6 +354,7 @@ class PyBuildExt(build_ext):
print("Failed to build these modules:")
print_three_column(failed)
print()
diff --git a/lang/python/python3/patches/016-adjust-config-paths.patch b/lang/python/python3/patches/016-adjust-config-paths.patch
index c08388729..dbd15cda9 100644
--- a/lang/python/python3/patches/016-adjust-config-paths.patch
+++ b/lang/python/python3/patches/016-adjust-config-paths.patch
@@ -10,7 +10,7 @@
global _config_vars
--- a/Lib/sysconfig.py
+++ b/Lib/sysconfig.py
-@@ -343,6 +343,7 @@ def get_makefile_filename():
+@@ -337,6 +337,7 @@ def get_makefile_filename():
def _get_sysconfigdata_name():
@@ -20,7 +20,7 @@
abi=sys.abiflags,
--- a/Makefile.pre.in
+++ b/Makefile.pre.in
-@@ -1350,7 +1350,7 @@ libinstall: build_all $(srcdir)/Modules/
+@@ -1390,7 +1390,7 @@ libinstall: build_all $(srcdir)/Modules/
esac; \
done; \
done
@@ -29,7 +29,7 @@
$(DESTDIR)$(LIBDEST); \
$(INSTALL_DATA) $(srcdir)/LICENSE $(DESTDIR)$(LIBDEST)/LICENSE.txt
ifeq (@COMPILE_ALL_TESTS@,yes)
-@@ -1487,7 +1487,7 @@ sharedinstall: sharedmods
+@@ -1525,7 +1525,7 @@ sharedinstall: sharedmods
--install-scripts=$(BINDIR) \
--install-platlib=$(DESTSHARED) \
--root=$(DESTDIR)/
@@ -40,7 +40,7 @@
# Here are a couple of targets for MacOSX again, to install a full
--- a/configure
+++ b/configure
-@@ -15014,7 +15014,7 @@ LDVERSION='$(VERSION)$(ABIFLAGS)'
+@@ -14981,7 +14981,7 @@ LDVERSION='$(VERSION)$(ABIFLAGS)'
$as_echo "$LDVERSION" >&6; }
@@ -51,7 +51,7 @@
LIBPL='$(prefix)'"/lib/python${VERSION}/config-${LDVERSION}-${PLATFORM_TRIPLET}"
--- a/configure.ac
+++ b/configure.ac
-@@ -4664,7 +4664,7 @@ AC_MSG_RESULT($LDVERSION)
+@@ -4682,7 +4682,7 @@ AC_MSG_RESULT($LDVERSION)
dnl define LIBPL after ABIFLAGS and LDVERSION is defined.
AC_SUBST(PY_ENABLE_SHARED)