aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorMichael Heimpold <mhei@heimpold.de>2022-07-19 19:20:11 +0200
committerGitHub <noreply@github.com>2022-07-19 19:20:11 +0200
commit61b31a31572954f106a4189ddd140a44b822d1dd (patch)
treefe41284e9a00d95bb38e239aaa3573f0d599835b /lang
parent59cadc7c65d5540b3e1bba26dfcd782cad98a5fe (diff)
parenta24a76783ea83225ebe242306fd3475bff34698c (diff)
Merge pull request #18919 from mhei/php8-full-libiconv
php8: fixup libiconv usage (refs openwrt/openwrt#10024)
Diffstat (limited to 'lang')
-rw-r--r--lang/php8/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/lang/php8/Makefile b/lang/php8/Makefile
index ebe56e037..e1aee1ba1 100644
--- a/lang/php8/Makefile
+++ b/lang/php8/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=php
PKG_VERSION:=8.1.7
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_MAINTAINER:=Michael Heimpold <mhei@heimpold.de>
PKG_LICENSE:=PHP-3.01
@@ -270,7 +270,13 @@ else
endif
ifneq ($(SDK)$(CONFIG_PACKAGE_php8-mod-iconv),)
- CONFIGURE_ARGS+= --with-iconv=shared,"$(ICONV_PREFIX)"
+ ifeq ($(CONFIG_BUILD_NLS),y)
+ CONFIGURE_VARS+= iconv_impl_name="gnu_libiconv"
+ CONFIGURE_ARGS+= --with-iconv=shared,"$(ICONV_PREFIX)"
+ else
+ CONFIGURE_VARS+= ac_cv_func_iconv=yes
+ CONFIGURE_ARGS+= --with-iconv=shared
+ endif
else
CONFIGURE_ARGS+= --without-iconv
endif
@@ -485,7 +491,6 @@ endif
CONFIGURE_VARS+= \
ac_cv_c_bigendian_php=$(if $(CONFIG_BIG_ENDIAN),yes,no) \
php_cv_cc_rpath="no" \
- iconv_impl_name="gnu_libiconv" \
ac_cv_php_xml2_config_path="$(STAGING_DIR)/host/bin/xml2-config" \
ac_cv_u8t_decompose=yes \
ac_cv_have_pcre2_jit=no