aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorEneas U de Queiroz <cote2004-github@yahoo.com>2019-05-14 17:05:44 -0300
committerEneas Queiroz <cote2004-github@yahoo.com>2019-05-21 10:53:52 -0300
commit5ea5d69ed3442885d51bbe4807fe40b471bace34 (patch)
treed357454453efed154029b943cafcaef8d783e202 /lang
parent1044ca095f0e0dd0ceafadc43e4c054eb8179a3a (diff)
openpyxl: bump to 2.6.2, add python3, fix depends
The current package does not work, due to missing dependencies, so they are being added now, along with python3 support. This versions brings many bugfixes, and the option to use defusedxml if available, protecting against many xml exploits. Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
Diffstat (limited to 'lang')
-rw-r--r--lang/python/openpyxl/Makefile65
1 files changed, 47 insertions, 18 deletions
diff --git a/lang/python/openpyxl/Makefile b/lang/python/openpyxl/Makefile
index 6837def20..fa583e177 100644
--- a/lang/python/openpyxl/Makefile
+++ b/lang/python/openpyxl/Makefile
@@ -7,41 +7,70 @@
include $(TOPDIR)/rules.mk
-PKG_NAME:=openpyxl
-PKG_VERSION:=2.5.9
-PKG_RELEASE:=2
+PKG_NAME:=python-openpyxl
+PKG_VERSION:=2.6.2
+PKG_RELEASE:=1
+
+PKG_MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>
PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENCE.rst
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE:=openpyxl-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/o/openpyxl
-PKG_HASH:=022c0f3fa1e873cc0ba20651c54dd5e6276fc4ff150b4060723add4fc448645e
-PKG_MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>
+PKG_HASH:=1d2af392cef8c8227bd2ac3ebe3a28b25aba74fd4fa473ce106065f0b73bfe2e
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-openpyxl-$(PKG_VERSION)
include $(INCLUDE_DIR)/package.mk
include ../python-package.mk
+include ../python3-package.mk
+
+PKG_UNPACK:=$(HOST_TAR) -C $(PKG_BUILD_DIR) --strip-components=1 -xzf $(DL_DIR)/$(PKG_SOURCE)
-define Package/openpyxl
+define Package/python-openpyxl/Default
SUBMENU:=Python
SECTION:=lang
CATEGORY:=Languages
TITLE:=A Python library to read/write Excel 2010 xlsx/xlsm files
URL:=https://openpyxl.readthedocs.org/
- DEPENDS:=+python +django
endef
-define Package/openpyxl/description
- A Python library to read/write Excel 2010 xlsx/xlsm files
+define Package/python-openpyxl
+ $(call Package/python-openpyxl/Default)
+ DEPENDS:= \
+ +PACKAGE_python-openpyxl:python \
+ +PACKAGE_python-openpyxl:python-defusedxml \
+ +PACKAGE_python-openpyxl:python-et_xmlfile \
+ +PACKAGE_python-openpyxl:python-jdcal
+ VARIANT:=python
+ # The PROVIDES below is deprecated and should be dropped with the next version.
+ PROVIDES:=openpyxl
endef
-define Build/Compile
- $(call Build/Compile/PyMod,,install --prefix=/usr --root=$(PKG_INSTALL_DIR))
+define Package/python3-openpyxl
+ $(call Package/python-openpyxl/Default)
+ DEPENDS:= \
+ +PACKAGE_python3-openpyxl:python3 \
+ +PACKAGE_python3-openpyxl:python3-defusedxml \
+ +PACKAGE_python3-openpyxl:python3-et_xmlfile \
+ +PACKAGE_python3-openpyxl:python3-jdcal
+ VARIANT:=python3
endef
-define Package/openpyxl/install
- $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
- $(CP) \
- $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
- $(1)$(PYTHON_PKG_DIR)
+define Package/python-openpyxl/description
+ A Python library to read/write Excel 2010 xlsx/xlsm files
endef
-$(eval $(call BuildPackage,openpyxl))
+define Package/python3-openpyxl/description
+$(call Package/python-openpyxl/description)
+.
+(Variant for Python3)
+endef
+
+$(eval $(call PyPackage,python-openpyxl))
+$(eval $(call BuildPackage,python-openpyxl))
+$(eval $(call BuildPackage,python-openpyxl-src))
+
+$(eval $(call Py3Package,python3-openpyxl))
+$(eval $(call BuildPackage,python3-openpyxl))
+$(eval $(call BuildPackage,python3-openpyxl-src))