aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorMichael Heimpold <mhei@heimpold.de>2020-01-26 21:53:14 +0100
committerMichael Heimpold <mhei@heimpold.de>2020-01-26 21:55:10 +0100
commit50b1cd3757497a569538d751f4681a40df1b1202 (patch)
treec2fd2d1cb2f413866eef83d07f4fe1835c615ad7 /lang
parent4f1c5e591993ff584dd1accab10610376bbbc3ab (diff)
php7: fix dependencies for mysqlnd (fixes #11113)
When during the build the openssl extension is also selected, then the mysqlnd extension depends on it, too. Signed-off-by: Michael Heimpold <mhei@heimpold.de>
Diffstat (limited to 'lang')
-rw-r--r--lang/php7/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/lang/php7/Makefile b/lang/php7/Makefile
index 5eedc05f9..828b7f6e7 100644
--- a/lang/php7/Makefile
+++ b/lang/php7/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=php
PKG_VERSION:=7.4.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_MAINTAINER:=Michael Heimpold <mhei@heimpold.de>
PKG_LICENSE:=PHP-3.01
@@ -607,7 +607,7 @@ $(eval $(call BuildModule,json,JSON))
$(eval $(call BuildModule,ldap,LDAP,+PACKAGE_php7-mod-ldap:libopenldap +PACKAGE_php7-mod-ldap:libsasl2))
$(eval $(call BuildModule,mbstring,MBString,+PACKAGE_php7-mod-mbstring:oniguruma))
$(eval $(call BuildModule,mysqli,MySQL Improved Extension,+PACKAGE_php7-mod-mysqli:php7-mod-mysqlnd,30))
-$(eval $(call BuildModule,mysqlnd,MySQL Native Driver))
+$(eval $(call BuildModule,mysqlnd,MySQL Native Driver,+PACKAGE_php7-mod-openssl:php7-mod-openssl))
$(eval $(call BuildModule,opcache,OPcache,,,zend))
$(eval $(call BuildModule,openssl,OpenSSL,+PACKAGE_php7-mod-openssl:libopenssl,15))
$(eval $(call BuildModule,pcntl,PCNTL))