aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-05-19 13:54:09 +0800
committerRosen Penev <rosenp@gmail.com>2023-05-24 06:08:51 +0300
commit5059cfccae8fda6837481569bdf3fff02144d614 (patch)
tree14281d9615c57e6e8571ba4ded40c7965d4c26a0 /lang
parent96de355818bdbaae51e17042806ef1856f784922 (diff)
borgbackup: Move from lang/python into utils
lang/python is meant for Python libraries and other packages closely related to the Python language. It makes more sense for borgbackup to be in utils instead. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang')
-rw-r--r--lang/python/borgbackup/Makefile64
1 files changed, 0 insertions, 64 deletions
diff --git a/lang/python/borgbackup/Makefile b/lang/python/borgbackup/Makefile
deleted file mode 100644
index 95fd7eaff..000000000
--- a/lang/python/borgbackup/Makefile
+++ /dev/null
@@ -1,64 +0,0 @@
-#
-# Copyright (C) 2023 Julien Malik <julien.malik@paraiso.me>
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=borgbackup
-PKG_VERSION:=1.2.4
-PKG_RELEASE:=3
-
-PYPI_NAME:=borgbackup
-PKG_HASH:=a4bd54e9469e81b7a30a6711423115abc818d9cd844ecb1ca0e6104bc5374da8
-
-PKG_LICENSE:=BSD-3-Clause
-PKG_LICENSE_FILES:=LICENSE
-PKG_MAINTAINER:=Julien Malik <julien.malik@paraiso.me>
-
-include ../pypi.mk
-include $(INCLUDE_DIR)/package.mk
-include ../python3-package.mk
-
-# see #20462 and #12942: email and urllib shall come with python3-light
-define Package/borgbackup
- SECTION:=lang
- CATEGORY:=Languages
- SUBMENU:=Python
- TITLE:=Deduplicated, encrypted, authenticated and compressed backups
- URL:=https://github.com/borgbackup/borg
- DEPENDS:= \
- +python3-light \
- +python3-codecs \
- +python3-email \
- +python3-logging \
- +python3-lzma \
- +python3-msgpack \
- +python3-packaging \
- +python3-pyfuse3 \
- +python3-readline \
- +python3-unittest \
- +python3-urllib \
- +python3-uuid \
- +libacl \
- +libopenssl \
- +liblz4 \
- +libzstd \
- +libxxhash
-endef
-
-define Package/borgbackup/description
- BorgBackup (short: Borg) is a deduplicating backup program.
- Optionally, it supports compression and authenticated encryption.
-
- The main goal of Borg is to provide an efficient and secure way to backup data.
- The data deduplication technique used makes Borg suitable for daily backups since only changes are stored. The authenticated encryption technique makes it suitable for backups to not fully trusted targets.
-endef
-
-PKG_BUILD_DEPENDS:=python-cython/host python-pkgconfig/host python-setuptools-scm/host
-
-$(eval $(call Py3Package,borgbackup))
-$(eval $(call BuildPackage,borgbackup))
-$(eval $(call BuildPackage,borgbackup-src))