aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorJavier Marcet <javier@marcet.info>2020-02-17 16:57:52 +0100
committerJavier Marcet <javier@marcet.info>2020-02-17 20:50:26 +0100
commit4f114a5ed470a0bd7ec4e762af3ea6a3a3768455 (patch)
treebc455ba12ae747511eea43650a0cb4c8eae7cff1 /lang
parent17891292d48a10f9049d9bca75ae71a53b616ea0 (diff)
python-stem: add a new package
Signed-off-by: Javier Marcet <javier@marcet.info>
Diffstat (limited to 'lang')
-rw-r--r--lang/python/python-stem/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/lang/python/python-stem/Makefile b/lang/python/python-stem/Makefile
new file mode 100644
index 000000000..46c0dce77
--- /dev/null
+++ b/lang/python/python-stem/Makefile
@@ -0,0 +1,37 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-stem
+PKG_VERSION:=1.8.0
+PKG_RELEASE:=1
+
+PYPI_NAME:=stem
+PKG_HASH:=a0b48ea6224e95f22aa34c0bc3415f0eb4667ddeae3dfb5e32a6920c185568c2
+
+PKG_MAINTAINER:=Javier Marcet <javier@marcet.info>
+PKG_LICENSE:=LGPL-3.0-only
+PKG_LICENSE_FILES:=LICENSE
+
+PYTHON3_PKG_SETUP_ARGS:=
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-stem
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=A controller library for Tor
+ URL:=https://stem.torproject.org/
+ DEPENDS:=+python3
+ VARIANT:=python3
+endef
+
+define Package/python3-stem/description
+ Stem is a Python controller library for Tor. With it you can use Tor's control
+ protocol to script against the Tor process, or build things such as Nyx.
+endef
+
+$(eval $(call Py3Package,python3-stem))
+$(eval $(call BuildPackage,python3-stem))
+$(eval $(call BuildPackage,python3-stem-src))