aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorMarcel Denia <naoir@gmx.net>2014-07-04 20:25:36 +0200
committerMarcel Denia <naoir@gmx.net>2014-07-07 22:54:14 +0200
commit4c57844f0f041f9b9d7e4980d2f8463c32bfad95 (patch)
tree13463dc3c8df9fe9b7beda6dcd0aefaf127da3a4 /lang
parente7263f63ca60a1fae5fb2623e315747133a9a2d5 (diff)
lang/perl: Add hack to make perl always use miniperl during build
Signed-off-by: Marcel Denia <naoir@gmx.net>
Diffstat (limited to 'lang')
-rw-r--r--lang/perl/patches/300-always_use_miniperl.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/lang/perl/patches/300-always_use_miniperl.patch b/lang/perl/patches/300-always_use_miniperl.patch
new file mode 100644
index 000000000..f8f8a65de
--- /dev/null
+++ b/lang/perl/patches/300-always_use_miniperl.patch
@@ -0,0 +1,27 @@
+--- a/Makefile.SH
++++ b/Makefile.SH
+@@ -315,22 +315,11 @@ MINIPERL = \$(LDLIBPTH) ./miniperl\$(EXE
+
+ !GROK!THIS!
+
+-case "$usecrosscompile$perl" in
+-define?*)
+- $spitshell >>$Makefile <<!GROK!THIS!
+-# Macros to invoke a copy of our fully operational perl during the build.
+-PERL_EXE = perl\$(EXE_EXT)
+-RUN_PERL = \$(LDLIBPTH) \$(RUN) $perl\$(EXE_EXT)
+-!GROK!THIS!
+- ;;
+-*)
+- $spitshell >>$Makefile <<!GROK!THIS!
++$spitshell >>$Makefile <<!GROK!THIS!
+ # Macros to invoke a copy of our fully operational perl during the build.
+ PERL_EXE = perl\$(EXE_EXT)
+-RUN_PERL = \$(LDLIBPTH) \$(RUN) ./perl\$(EXE_EXT) -Ilib
++RUN_PERL = \$(LDLIBPTH) \$(RUN) ./miniperl\$(EXE_EXT) -Ilib
+ !GROK!THIS!
+- ;;
+-esac
+
+ $spitshell >>$Makefile <<!GROK!THIS!
+ # Macros to run our tests