aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorJan Pavlinec <jan.pavlinec@nic.cz>2019-10-31 13:26:48 +0100
committerJan Pavlinec <jan.pavlinec@nic.cz>2019-11-01 12:36:38 +0100
commit4bade3b2f7448150d6ca210a1bd27b352efe7b42 (patch)
tree1f35ac1a22e2d97e515ec51d8fcc24616a915c1d /lang
parent5ae85b79526d4b0197d3581d349a2f7b6932bd52 (diff)
python-more-itertools: add new package
Signed-off-by: Jan Pavlinec <jan.pavlinec@nic.cz>
Diffstat (limited to 'lang')
-rw-r--r--lang/python/python-more-itertools/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/lang/python/python-more-itertools/Makefile b/lang/python/python-more-itertools/Makefile
new file mode 100644
index 000000000..5feb3df7c
--- /dev/null
+++ b/lang/python/python-more-itertools/Makefile
@@ -0,0 +1,42 @@
+#
+# Copyright (C) 2019 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-more-itertools
+PKG_VERSION:=7.2.0
+PKG_RELEASE:=1
+
+PYPI_NAME:=more-itertools
+PKG_HASH:=409cd48d4db7052af495b09dec721011634af3753ae1ef92d2b32f73a745f832
+
+PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec@nic.cz>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-more-itertools
+ SUBMENU:=Python
+ SECTION:=lang
+ CATEGORY:=Languages
+ TITLE:=More routines for operating on iterables, beyond itertools
+ URL:=https://github.com/erikrose/more-itertools
+ DEPENDS:=+python3-light
+ VARIANT:=python3
+endef
+
+define Package/python3-more-itertools/description
+ more-itertools library collects additional building blocks,
+ recipes, and routines for working with Python iterables.
+endef
+
+$(eval $(call Py3Package,python3-more-itertools))
+$(eval $(call BuildPackage,python3-more-itertools))
+$(eval $(call BuildPackage,python3-more-itertools-src))