aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorMarko Ratkaj <marko.ratkaj@sartura.hr>2018-11-30 16:06:56 +0100
committerGitHub <noreply@github.com>2018-11-30 16:06:56 +0100
commit4b576f2ddcb260c2a682f2d4f2f9a2892f6f54da (patch)
tree93ca441ba996d4c167015744e41f357f49a53dfa /lang
parent5147125784979236a7d671cf72ab4505e5d09f05 (diff)
parentae53f9b6d8b61bc7fecb009c6ef123b379564c70 (diff)
Merge pull request #7475 from miska/mozilla
node-mozilla-iot-gateway: Cleanup init script
Diffstat (limited to 'lang')
-rw-r--r--lang/node-mozilla-iot-gateway/Makefile2
-rw-r--r--lang/node-mozilla-iot-gateway/files/mozilla-iot-gateway.init22
2 files changed, 9 insertions, 15 deletions
diff --git a/lang/node-mozilla-iot-gateway/Makefile b/lang/node-mozilla-iot-gateway/Makefile
index 9bf7d4b1a..d2252259a 100644
--- a/lang/node-mozilla-iot-gateway/Makefile
+++ b/lang/node-mozilla-iot-gateway/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NPM_NAME:=mozilla-iot-gateway
PKG_NAME:=node-$(PKG_NPM_NAME)
PKG_VERSION:=0.6.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_REV:=df2d06def2051238bde7b8e5ee306262235d4c9f
PKG_SOURCE_PROTO:=git
diff --git a/lang/node-mozilla-iot-gateway/files/mozilla-iot-gateway.init b/lang/node-mozilla-iot-gateway/files/mozilla-iot-gateway.init
index 7bd3836ca..8ed67fcac 100644
--- a/lang/node-mozilla-iot-gateway/files/mozilla-iot-gateway.init
+++ b/lang/node-mozilla-iot-gateway/files/mozilla-iot-gateway.init
@@ -2,26 +2,20 @@
START=99
+USE_PROCD=1
+
HOME=/root
MOZIOT_HOME="${HOME}/.mozilla-iot"
export PATH="/opt/mozilla-iot/gateway/tools:${PATH}"
-run_app() {
- cd /opt/mozilla-iot/gateway
-
- echo "node version"
- node --version
- echo "npm version"
- npm --version
- echo "Starting gateway ..."
- npm start
-}
-
-start()
+start_service()
{
mkdir -p /usr/etc/
ln -sf /etc/openzwave /usr/etc/openzwave
- mkdir -p "${MOZIOT_HOME}/log"
- run_app &> "${MOZIOT_HOME}/log/run-app.log" &
+ procd_open_instance mozilla-iot-gateway
+ procd_set_param command /usr/bin/npm start --prefix /opt/mozilla-iot/gateway
+ procd_set_param stdout 1
+ procd_set_param stderr 1
+ procd_close_instance
}