aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-08-03 02:22:01 -0700
committerGitHub <noreply@github.com>2020-08-03 02:22:01 -0700
commit4860c5cc5be548e3c7fd77d29fe0446c9d518d85 (patch)
treeaea1ba2b4cc936af68f5ee972e8b925bcec7a5bd /lang
parent3ae4b3f016e0133e3a0bb050193b251bb31ec300 (diff)
parentb40c40151c2ac3dd11d908a0548ac97e6b5c8455 (diff)
Merge pull request #12997 from neheb/pyt
python3: fix host compilation with clang
Diffstat (limited to 'lang')
-rw-r--r--lang/python/python3-host.mk2
-rw-r--r--lang/python/python3/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/lang/python/python3-host.mk b/lang/python/python3-host.mk
index 567b56d59..80a1bb110 100644
--- a/lang/python/python3-host.mk
+++ b/lang/python/python3-host.mk
@@ -31,7 +31,7 @@ HOST_PYTHON3_VARS = \
LDSHARED="$(HOSTCC) -shared" \
CFLAGS="$(HOST_CFLAGS)" \
CPPFLAGS="$(HOST_CPPFLAGS) -I$(HOST_PYTHON3_INC_DIR)" \
- LDFLAGS="$(HOST_LDFLAGS) -lpython$(PYTHON3_VERSION) -Wl$(comma)-rpath=$(STAGING_DIR_HOSTPKG)/lib" \
+ LDFLAGS="$(HOST_LDFLAGS) -lpython$(PYTHON3_VERSION) -Wl$(comma)-rpath$(comma)$(STAGING_DIR_HOSTPKG)/lib" \
PYTHONPATH="$(HOST_PYTHON3PATH)" \
PYTHONDONTWRITEBYTECODE=0 \
PYTHONOPTIMIZE=""
diff --git a/lang/python/python3/Makefile b/lang/python/python3/Makefile
index 0dcad69c6..f5a08382f 100644
--- a/lang/python/python3/Makefile
+++ b/lang/python/python3/Makefile
@@ -11,7 +11,7 @@ include $(TOPDIR)/rules.mk
include ../python3-version.mk
PKG_NAME:=python3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_VERSION:=$(PYTHON3_VERSION).$(PYTHON3_VERSION_MICRO)
PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz