aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2019-11-05 02:20:37 +0800
committerJeffery To <jeffery.to@gmail.com>2019-11-05 02:20:37 +0800
commit446bc30c527e8c6d24279f21e9e4f7562f98ab67 (patch)
treedd5f9b160a2b9960c8b61f0ed5bb5d1296ffca4c /lang
parentc17af1cd505ca4f5ab6a940d28e8598667375a5b (diff)
python: Remove PKG_BUILD_DIR/PKG_UNPACK sections from readme
PKG_BUILD_DIR now takes variants into account (openwrt/openwrt@e545fac8d968864a965edb9e50c6f90940b0a6c9), so it should not be necessary for Python packages to set these variables anymore. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang')
-rw-r--r--lang/python/README.md27
1 files changed, 0 insertions, 27 deletions
diff --git a/lang/python/README.md b/lang/python/README.md
index 61325b7d5..c6bbd20a8 100644
--- a/lang/python/README.md
+++ b/lang/python/README.md
@@ -171,33 +171,6 @@ This section will describe both, and then it can be inferred which is for which.
Packaging for both Python & Python3 uses the `VARIANT` mechanism for packaging inside OpenWrt. (#### FIXME: find a link for this later if it exists)
-### PKG_BUILD_DIR
-
-It's important when packaging for both Python & Python3 to override this variable, so that the build directory differs for each variant.
-
-Typically it's just something like:
-```
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-pyasn1-$(PKG_VERSION)
-```
-Where `pyasn1` should be some other name, or maybe `PKG_NAME`
-
-This should be added before this include:
-```
-include $(INCLUDE_DIR)/package.mk
-```
-
-### PKG_UNPACK
-
-In many cases, this needs to be overriden. This is usually because the way Python packages are archived, don't follow the convention of other `tar.gz` packages.
-
-So, something like:
-```
-PKG_UNPACK=$(HOST_TAR) -C $(PKG_BUILD_DIR) --strip-components=1 -xzf $(DL_DIR)/$(PKG_SOURCE)
-```
-should be added.
-
-It's not important whether this is after or before `include $(INCLUDE_DIR)/package.mk`
-
### Include python[3]-package.mk
If packaging for Python, add this after `include $(INCLUDE_DIR)/package.mk`