aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-04-22 15:35:03 -0700
committerGitHub <noreply@github.com>2020-04-22 15:35:03 -0700
commit3d9916b07f7963f3904d686d2a976e015fabe01f (patch)
treecd80c8144b5e301ffbd520e6ab638153bff5a944 /lang
parentd3ce675c025d999e5fffdf76472201a209d26b88 (diff)
parent125f9fca87be1e98ecc76e49cef467904d905741 (diff)
Merge pull request #11934 from jefferyto/python-gnupg-0.4.6
python-gnupg: Update to 0.4.6
Diffstat (limited to 'lang')
-rw-r--r--lang/python/python-gnupg/Makefile40
1 files changed, 16 insertions, 24 deletions
diff --git a/lang/python/python-gnupg/Makefile b/lang/python/python-gnupg/Makefile
index bf782f948..6a4f99b2c 100644
--- a/lang/python/python-gnupg/Makefile
+++ b/lang/python/python-gnupg/Makefile
@@ -5,16 +5,16 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=python-gnupg
-PKG_VERSION:=0.4.4
-PKG_RELEASE:=3
+PKG_VERSION:=0.4.6
+PKG_RELEASE:=1
PYPI_NAME:=$(PKG_NAME)
-PKG_HASH:=45daf020b370bda13a1429c859fcdff0b766c0576844211446f9266cae97fb0e
+PKG_HASH:=3aa0884b3bd414652c2385b9df39e7b87272c2eca1b8fcc3089bc9e58652019a
-PKG_LICENSE:=GPL-3.0-or-later
-PKG_LICENSE_FILES:=LICENSE
+PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILES:=LICENSE.txt
PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
-PKG_CPE_ID:=cpe:/a:python-gnupg_project:python-gnupg
+PKG_CPE_ID:=cpe:/a:python:python-gnupg
include ../pypi.mk
include $(INCLUDE_DIR)/package.mk
@@ -24,28 +24,20 @@ define Package/python3-gnupg
SECTION:=lang
CATEGORY:=Languages
SUBMENU:=Python
- TITLE:=python3-gnupg
- URL:=https://gnupg.readthedocs.io/en/latest/
- DEPENDS:=+gnupg +python3-light
+ TITLE:=A wrapper for GnuPG
+ URL:=https://docs.red-dove.com/python-gnupg/
+ DEPENDS:=+gnupg +python3-light +python3-logging
endef
define Package/python3-gnupg/description
-A Python wrapper for GnuPG
-
-This module allows easy access to GnuPG.s key management, encryption
-and signature functionality from Python programs, by interacting with
-GnuPG through file descriptors. Input arguments are strictly checked
-and sanitised, and therefore this module should be safe to use in
-networked applications requiring direct user input. It is intended for
-use on Windows, MacOS X, BSD, or Linux, with Python 2.6, Python 2.7,
-Python 3.3, Python 3.4, or PyPy.
-endef
-
-define Py3Build/Compile
- $(call Python3/ModSetup,,\
- install --prefix="/usr" --root="$(PKG_INSTALL_DIR)" \
- )
+ The gnupg module allows Python programs to make use of the
+ functionality provided by the GNU Privacy Guard (abbreviated GPG or
+ GnuPG). Using this module, Python programs can encrypt and decrypt
+ data, digitally sign documents and verify digital signatures, manage
+ (generate, list and delete) encryption keys, using Public Key
+ Infrastructure (PKI) encryption technology based on OpenPGP.
endef
$(eval $(call Py3Package,python3-gnupg))
$(eval $(call BuildPackage,python3-gnupg))
+$(eval $(call BuildPackage,python3-gnupg-src))