aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-03-09 23:57:20 -0800
committerGitHub <noreply@github.com>2021-03-09 23:57:20 -0800
commit31d37ec6d5e517cc1dd8fc3db4d3c24625838d49 (patch)
tree10f7b53fdb2aceac3f61347a6c60d59906691733 /lang
parent71cf4a74ff22f7c783d21791c58e55e81e1f0a4a (diff)
parenta63bc367b7bce448d98c865da1ec2ee3e3741ff9 (diff)
Merge pull request #15069 from neheb/seli
selinux updates
Diffstat (limited to 'lang')
-rw-r--r--lang/python/python3-libselinux/Makefile6
-rw-r--r--lang/python/python3-libselinux/patches/010-setup-py-custom-cc.patch2
-rw-r--r--lang/python/python3-libselinux/patches/030-musl12x.patch66
-rw-r--r--lang/python/python3-libsemanage/Makefile4
4 files changed, 6 insertions, 72 deletions
diff --git a/lang/python/python3-libselinux/Makefile b/lang/python/python3-libselinux/Makefile
index 159e09dc3..18caa46b4 100644
--- a/lang/python/python3-libselinux/Makefile
+++ b/lang/python/python3-libselinux/Makefile
@@ -7,13 +7,13 @@ include $(TOPDIR)/rules.mk
SRC_NAME:=libselinux
PKG_NAME:=python3-$(SRC_NAME)
-PKG_VERSION:=3.1
-PKG_RELEASE:=2
+PKG_VERSION:=3.2
+PKG_RELEASE:=1
PKG_BUILD_DIR:=$(BUILD_DIR)/python-libselinux/$(SRC_NAME)-$(PKG_VERSION)
PKG_SOURCE:=$(SRC_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/SELinuxProject/selinux/releases/download/20200710
-PKG_HASH:=ea5dcbb4d859e3f999c26a13c630da2f16dff9462e3cc8cb7b458ac157d112e7
+PKG_HASH:=df758ef1d9d4811051dd901ea6b029ae334ffd7c671c128beb16bce1e25ac161
PKG_BUILD_DEPENDS:=swig/host
PKG_MAINTAINER:=Thomas Petazzoni <thomas.petazzoni@bootlin.com>
diff --git a/lang/python/python3-libselinux/patches/010-setup-py-custom-cc.patch b/lang/python/python3-libselinux/patches/010-setup-py-custom-cc.patch
index 6b86f6fa1..8fe816588 100644
--- a/lang/python/python3-libselinux/patches/010-setup-py-custom-cc.patch
+++ b/lang/python/python3-libselinux/patches/010-setup-py-custom-cc.patch
@@ -1,6 +1,6 @@
--- a/src/Makefile
+++ b/src/Makefile
-@@ -131,7 +131,7 @@ SWIGRUBY = swig -Wall -ruby -o $(SWIGRUB
+@@ -139,7 +139,7 @@ SWIGRUBY = swig -Wall -ruby -o $(SWIGRUB
all: $(LIBA) $(LIBSO) $(LIBPC)
pywrap: all selinuxswig_python_exception.i
diff --git a/lang/python/python3-libselinux/patches/030-musl12x.patch b/lang/python/python3-libselinux/patches/030-musl12x.patch
deleted file mode 100644
index 9eea417bc..000000000
--- a/lang/python/python3-libselinux/patches/030-musl12x.patch
+++ /dev/null
@@ -1,66 +0,0 @@
-From 398d2ceef92cb1baac18e6b34a1a8e1bf41296cd Mon Sep 17 00:00:00 2001
-From: Nicolas Iooss <nicolas.iooss@m4x.org>
-Date: Tue, 16 Feb 2021 22:13:28 +0100
-Subject: [PATCH] libselinux: rename gettid() to something which never
- conflicts with the libc
-
-Musl recently added a wrapper for gettid() syscall. There is no way to
-detect this new version in a reliable way, so rename our gettid()
-wrapper to a non-conflicting name.
-
-Introduce a new function which, when using a libc known to provide a
-wrapper for gettid(), calls it, and which, otherwise, performs the
-syscall directly.
-
-Anyway this function is only used on systems where /proc/thread-self
-does not exist, which are therefore running Linux<3.17.
-
-Fixes: https://github.com/SELinuxProject/selinux/issues/282
-Signed-off-by: Nicolas Iooss <nicolas.iooss@m4x.org>
-Acked-by: Petr Lautrbach <plautrba@redhat.com>
----
- src/procattr.c | 18 ++++++++++--------
- 1 file changed, 10 insertions(+), 8 deletions(-)
-
---- a/src/procattr.c
-+++ b/src/procattr.c
-@@ -25,21 +25,23 @@ static __thread char destructor_initiali
- /* Bionic and glibc >= 2.30 declare gettid() system call wrapper in unistd.h and
- * has a definition for it */
- #ifdef __BIONIC__
-- #define OVERRIDE_GETTID 0
-+ #define HAVE_GETTID 1
- #elif !defined(__GLIBC_PREREQ)
-- #define OVERRIDE_GETTID 1
-+ #define HAVE_GETTID 0
- #elif !__GLIBC_PREREQ(2,30)
-- #define OVERRIDE_GETTID 1
-+ #define HAVE_GETTID 0
- #else
-- #define OVERRIDE_GETTID 0
-+ #define HAVE_GETTID 1
- #endif
-
--#if OVERRIDE_GETTID
--static pid_t gettid(void)
-+static pid_t selinux_gettid(void)
- {
-+#if HAVE_GETTID
-+ return gettid();
-+#else
- return syscall(__NR_gettid);
--}
- #endif
-+}
-
- static void procattr_thread_destructor(void __attribute__((unused)) *unused)
- {
-@@ -94,7 +96,7 @@ static int openattr(pid_t pid, const cha
- if (fd >= 0 || errno != ENOENT)
- goto out;
- free(path);
-- tid = gettid();
-+ tid = selinux_gettid();
- rc = asprintf(&path, "/proc/self/task/%d/attr/%s", tid, attr);
- } else {
- errno = EINVAL;
diff --git a/lang/python/python3-libsemanage/Makefile b/lang/python/python3-libsemanage/Makefile
index 5cb91ef76..c1670e567 100644
--- a/lang/python/python3-libsemanage/Makefile
+++ b/lang/python/python3-libsemanage/Makefile
@@ -7,13 +7,13 @@ include $(TOPDIR)/rules.mk
SRC_NAME:=libsemanage
PKG_NAME:=python3-$(SRC_NAME)
-PKG_VERSION:=3.1
+PKG_VERSION:=3.2
PKG_RELEASE:=1
PKG_BUILD_DIR:=$(BUILD_DIR)/python-libsemanage/$(SRC_NAME)-$(PKG_VERSION)
PKG_SOURCE:=$(SRC_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/SELinuxProject/selinux/releases/download/20200710
-PKG_HASH:=22d6c75526e40d1781c30bcf29abf97171bdfe6780923f11c8e1c76a75a21ff8
+PKG_HASH:=d722a55ca4fe2d4e2b30527720db657e6238b28079e69e2e4affeb8e733ee511
PKG_BUILD_DEPENDS:=swig/host
PKG_MAINTAINER:=Thomas Petazzoni <thomas.petazzoni@bootlin.com>