aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2019-06-29 11:46:25 +0200
committerKarel Kočí <karel.koci@nic.cz>2019-07-08 15:56:50 +0200
commit306e276a3b829612786ce47625acdd12f4d59118 (patch)
tree747445b501640eb921defeeceb10f50d69c03c43 /lang
parentf8d595169a7f06090dac78b28531562fa681e35e (diff)
python-intelhex: add new package
This is Python library to parse, generate and in general handle files in Intel HEX format. Signed-off-by: Karel Kočí <cynerd@email.cz>
Diffstat (limited to 'lang')
-rw-r--r--lang/python/python-intelhex/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/lang/python/python-intelhex/Makefile b/lang/python/python-intelhex/Makefile
new file mode 100644
index 000000000..4f9619bc1
--- /dev/null
+++ b/lang/python/python-intelhex/Makefile
@@ -0,0 +1,42 @@
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-intelhex
+PKG_VERSION:=2.2.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=intelhex-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/i/intelhex/
+PKG_HASH:=009d8511e0d50639230c39af9607deee771cf026f67ef7507a8c3fd4fa927832
+PKG_BUILD_DIR:=$(BUILD_DIR)/intelhex-$(PKG_VERSION)
+
+PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
+PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILES:=LICENSE.txt
+
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-intelhex
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=python3-intelhex
+ URL:=https://github.com/bialix/intelhex
+ DEPENDS:=+python3-light
+ VARIANT:=python3
+endef
+
+define Package/python3-intelhex/description
+ This work implements an intelhex Python library to read, write, create from
+ scratch and manipulate data from Intel HEX file format.
+endef
+
+PYTHON3_PKG_SETUP_ARGS:=
+
+$(eval $(call Py3Package,python3-intelhex))
+$(eval $(call BuildPackage,python3-intelhex))
+$(eval $(call BuildPackage,python3-intelhex-src))