aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorAlexandru Ardelean <ardeleanalex@gmail.com>2019-10-08 16:53:35 +0300
committerAlexandru Ardelean <ardeleanalex@gmail.com>2019-10-08 16:53:36 +0300
commit2f19a94d65bfca685e00a27e9000e699cfe20ad5 (patch)
tree3224a0e1daed6124291bb47e4f6487ce9c173fed /lang
parent5f7fc18ce7be2513370aaf4b050987afa7262ed2 (diff)
python[3]-simplejson: drop tests from simplejson package
These tests take-up a bit of space. And they aren't typically needed. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Diffstat (limited to 'lang')
-rw-r--r--lang/python/python-simplejson/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/lang/python/python-simplejson/Makefile b/lang/python/python-simplejson/Makefile
index a97520020..6b2d45432 100644
--- a/lang/python/python-simplejson/Makefile
+++ b/lang/python/python-simplejson/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=python-simplejson
PKG_VERSION:=3.16.0
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_LICENSE:=MIT
PKG_CPE_ID:=cpe:/a:simplejson_project:simplejson
@@ -56,6 +56,16 @@ $(call Package/python-simplejson/description)
(Variant for Python3)
endef
+define PyPackage/python-simplejson/filespec
++|$(PYTHON_PKG_DIR)
+-|$(PYTHON_PKG_DIR)/simplejson/tests
+endef
+
+define Py3Package/python3-simplejson/filespec
++|$(PYTHON3_PKG_DIR)
+-|$(PYTHON3_PKG_DIR)/simplejson/tests
+endef
+
$(eval $(call PyPackage,python-simplejson))
$(eval $(call BuildPackage,python-simplejson))
$(eval $(call BuildPackage,python-simplejson-src))