aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorJosef Schlehofer <pepe.schlehofer@gmail.com>2019-03-24 17:58:15 +0100
committerJosef Schlehofer <pepe.schlehofer@gmail.com>2019-04-01 02:29:26 +0200
commit2edf5034f1c09fe60af52087abe7b6fcef9433fc (patch)
treef5d740710d21deb149b9d12574345b0bfbd577b6 /lang
parent80f2556eb23b9e61c4eb34df134c0cf0b970c97a (diff)
python-aiohttp: add a new package
Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
Diffstat (limited to 'lang')
-rw-r--r--lang/python/python-aiohttp/Makefile52
1 files changed, 52 insertions, 0 deletions
diff --git a/lang/python/python-aiohttp/Makefile b/lang/python/python-aiohttp/Makefile
new file mode 100644
index 000000000..f1de0b55b
--- /dev/null
+++ b/lang/python/python-aiohttp/Makefile
@@ -0,0 +1,52 @@
+#
+# Copyright (C) 2019 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=aiohttp
+PKG_VERSION:=3.5.4
+PKG_RELEASE:=1
+
+PKG_SOURCE:=aiohttp-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/a/aiohttp/
+PKG_HASH:=9c4c83f4fa1938377da32bc2d59379025ceeee8e24b89f72fcbccd8ca22dc9bf
+
+PKG_MAINTAINER:=Josef Schlehofer <pepe.schlehofer@gmail.com>
+PKG_LICENSE:=Apache-2.0
+PKG_LICENSE_FILES:=LICENSE
+PKG_CPE_ID:=cpe:/a:aio-libs_project:aiohttp
+
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-aiohttp
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=Async http client/server framework (asyncio)
+ URL:=https://github.com/aio-libs/aiohttp
+ DEPENDS:= \
+ +python3-light \
+ +python3-attrs \
+ +python3-chardet \
+ +python3-multidict \
+ +python3-async-timeout \
+ +python3-yarl \
+ +python3-logging \
+ +python3-codecs \
+ +python3-cgi \
+ +python3-openssl
+ VARIANT:=python3
+endef
+
+define Package/python3-aiohttp/description
+Asynchronous HTTP client/server framework for asyncio and Python3
+endef
+
+$(eval $(call Py3Package,python3-aiohttp))
+$(eval $(call BuildPackage,python3-aiohttp))
+$(eval $(call BuildPackage,python3-aiohttp-src))