aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorAlexandru Ardelean <ardeleanalex@gmail.com>2020-04-17 11:25:15 +0300
committerAlexandru Ardelean <ardeleanalex@gmail.com>2020-04-17 11:25:16 +0300
commit1bb81789de31a49dc89a406d085e8473e61cea5c (patch)
treeec5c26a8f1d22c76ee377ce5c6e376c0c2bab7e7 /lang
parentc11aaead910d5351d0f3fd4e4460ad98336fa0d4 (diff)
django-constance: drop package
This was needed for Seafile up to a certain version. Since it's not required anymore by any other package/known-user, remove it. Should be installable via pip or manually. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Diffstat (limited to 'lang')
-rw-r--r--lang/python/django-constance/Makefile48
1 files changed, 0 insertions, 48 deletions
diff --git a/lang/python/django-constance/Makefile b/lang/python/django-constance/Makefile
deleted file mode 100644
index 0d5da2aae..000000000
--- a/lang/python/django-constance/Makefile
+++ /dev/null
@@ -1,48 +0,0 @@
-#
-# Copyright (C) 2007-2017 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=django-constance
-PKG_VERSION:=2.3.1
-PKG_RELEASE:=5
-
-PYPI_NAME:=$(PKG_NAME)
-PKG_HASH:=a49735063b2c30015d2e52a90609ea9798da722ed070f091de51714758a5d018
-
-PKG_MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>
-PKG_LICENSE:=BSD-3-Clause
-
-include ../pypi.mk
-include $(INCLUDE_DIR)/package.mk
-include ../python3-package.mk
-
-define Package/python-django-constance/Default
- SUBMENU:=Python
- SECTION:=lang
- CATEGORY:=Languages
- TITLE:=Django live settings with pluggable backends, including Redis.
- URL:=https://github.com/jazzband/django-constance
-endef
-
-define Package/python3-django-constance
-$(call Package/python-django-constance/Default)
- DEPENDS:= \
- +PACKAGE_python3-django-constance:python3 \
- +PACKAGE_python3-django-constance:python3-django1
- VARIANT:=python3
-endef
-
-define Package/python3-django-constance/description
- Django live settings with pluggable backends, including Redis.
-.
-(Variant for Python3)
-endef
-
-$(eval $(call Py3Package,python3-django-constance))
-$(eval $(call BuildPackage,python3-django-constance))
-$(eval $(call BuildPackage,python3-django-constance-src))