aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2019-01-13 05:59:20 +0800
committerJeffery To <jeffery.to@gmail.com>2019-01-13 05:59:20 +0800
commit19c3f37f0fb7f22ba81c5724e8d2268c432db2b1 (patch)
treed16967f1c238ea005d8792efa3e878636635fa1e /lang
parentcf327c3d89605601d8a137c88f45d55e958e2cd7 (diff)
python: Fix lib2to3 fixes search
This is the patch from c98b12d9a920ede376d1eaef0da0c0da9d26d6b3 (#7931), applied for python 2. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang')
-rw-r--r--lang/python/python/Makefile2
-rw-r--r--lang/python/python/patches/017_lib2to3_fix_pyc_search.patch17
2 files changed, 18 insertions, 1 deletions
diff --git a/lang/python/python/Makefile b/lang/python/python/Makefile
index d27882883..a065edaa0 100644
--- a/lang/python/python/Makefile
+++ b/lang/python/python/Makefile
@@ -12,7 +12,7 @@ include ../python-version.mk
PKG_NAME:=python
PKG_VERSION:=$(PYTHON_VERSION).$(PYTHON_VERSION_MICRO)
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://www.python.org/ftp/python/$(PKG_VERSION)
diff --git a/lang/python/python/patches/017_lib2to3_fix_pyc_search.patch b/lang/python/python/patches/017_lib2to3_fix_pyc_search.patch
new file mode 100644
index 000000000..5972914bd
--- /dev/null
+++ b/lang/python/python/patches/017_lib2to3_fix_pyc_search.patch
@@ -0,0 +1,17 @@
+diff --git a/Lib/lib2to3/refactor.py b/Lib/lib2to3/refactor.py
+index 7841b99..1e0d3b3 100644
+--- a/Lib/lib2to3/refactor.py
++++ b/Lib/lib2to3/refactor.py
+@@ -37,6 +37,12 @@ def get_all_fix_names(fixer_pkg, remove_prefix=True):
+ if remove_prefix:
+ name = name[4:]
+ fix_names.append(name[:-3])
++ if name.startswith("fix_") and name.endswith(".pyc"):
++ if remove_prefix:
++ name = name[4:]
++ name = name[:-4]
++ if name not in fix_names:
++ fix_names.append(name)
+ return fix_names
+
+