aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorDeng Qingfang <dengqf6@mail2.sysu.edu.cn>2019-01-28 14:38:44 +0800
committerDeng Qingfang <dengqf6@mail2.sysu.edu.cn>2019-03-30 17:11:50 +0800
commit17496030e2645b30fc0793b3c2104b275daa3c08 (patch)
tree200a37da5d7b167d1952b566b83ccfce24385fc6 /lang
parent149afa5dcbf9c236ef42b476c47dbe687487d6e6 (diff)
treewide: add missing PKGARCH:=all to non-binary packages
Packages such as Perl, Lua, shell scripts don't generate binary files. Add PKGARCH:=all to them. Signed-off-by: Deng Qingfang <dengqf6@mail2.sysu.edu.cn>
Diffstat (limited to 'lang')
-rw-r--r--lang/dkjson/Makefile1
-rw-r--r--lang/json4lua/Makefile1
-rw-r--r--lang/lua-bencode/Makefile1
-rw-r--r--lang/lua-mobdebug/Makefile1
-rw-r--r--lang/lua-wsapi/Makefile1
-rw-r--r--lang/lua-xavante/Makefile1
-rw-r--r--lang/luasoap/Makefile1
-rw-r--r--lang/uuid/Makefile1
8 files changed, 8 insertions, 0 deletions
diff --git a/lang/dkjson/Makefile b/lang/dkjson/Makefile
index b5ecfd522..3f0f6fd9c 100644
--- a/lang/dkjson/Makefile
+++ b/lang/dkjson/Makefile
@@ -27,6 +27,7 @@ define Package/dkjson
URL:=http://dkolf.de/src/dkjson-lua.fsl/home
MAINTAINER:=Lars Gierth <larsg@systemli.org>
DEPENDS:=+lua
+ PKGARCH:=all
endef
define Package/dkjson/description
diff --git a/lang/json4lua/Makefile b/lang/json4lua/Makefile
index 33892d2f6..6a4f8af70 100644
--- a/lang/json4lua/Makefile
+++ b/lang/json4lua/Makefile
@@ -29,6 +29,7 @@ define Package/json4lua
TITLE:=json4lua
URL:=https://github.com/amrhassan/json4lua
DEPENDS:=+lua +luasocket
+ PKGARCH:=all
endef
define Package/json4lua/description
diff --git a/lang/lua-bencode/Makefile b/lang/lua-bencode/Makefile
index e256fe822..3edee239f 100644
--- a/lang/lua-bencode/Makefile
+++ b/lang/lua-bencode/Makefile
@@ -27,6 +27,7 @@ define Package/lua-bencode
TITLE:=lua-bencode
URL:=https://bitbucket.org/wilhelmy/lua-bencode
DEPENDS:=+lua
+ PKGARCH:=all
endef
define Package/lua-bencode/description
diff --git a/lang/lua-mobdebug/Makefile b/lang/lua-mobdebug/Makefile
index bc0bb8cd3..b1c387d42 100644
--- a/lang/lua-mobdebug/Makefile
+++ b/lang/lua-mobdebug/Makefile
@@ -32,6 +32,7 @@ define Package/lua-mobdebug
TITLE:=Lua-MobDebug
URL:=https://github.com/pkulchenko/MobDebug
DEPENDS:=+lua
+ PKGARCH:=all
endef
define Package/lua-mobdebug/description
diff --git a/lang/lua-wsapi/Makefile b/lang/lua-wsapi/Makefile
index d1ac559dc..71e5aad55 100644
--- a/lang/lua-wsapi/Makefile
+++ b/lang/lua-wsapi/Makefile
@@ -31,6 +31,7 @@ define Package/lua-wsapi/Default
TITLE:=Lua WSAPI
URL:=https://keplerproject.github.io/wsapi/
DEPENDS:= +lua
+ PKGARCH:=all
endef
define Package/lua-wsapi/Default/description
diff --git a/lang/lua-xavante/Makefile b/lang/lua-xavante/Makefile
index acef0c2eb..9b870aa5c 100644
--- a/lang/lua-xavante/Makefile
+++ b/lang/lua-xavante/Makefile
@@ -31,6 +31,7 @@ define Package/lua-xavante
TITLE:=Xavante Web Server
URL:=https://keplerproject.github.io/xavante/
DEPENDS:= +lua
+ PKGARCH:=all
endef
define Package/lua-xavante/description
diff --git a/lang/luasoap/Makefile b/lang/luasoap/Makefile
index de88fcf98..f07c635a8 100644
--- a/lang/luasoap/Makefile
+++ b/lang/luasoap/Makefile
@@ -30,6 +30,7 @@ define Package/luasoap
TITLE:=LuaSOAP
URL:=https://github.com/tomasguisasola/luasoap
DEPENDS:=+lua +luaexpat +luasec +luasocket
+ PKGARCH:=all
endef
define Package/luasoap/description
diff --git a/lang/uuid/Makefile b/lang/uuid/Makefile
index 9d9b4deef..d1ca40770 100644
--- a/lang/uuid/Makefile
+++ b/lang/uuid/Makefile
@@ -32,6 +32,7 @@ define Package/uuid
TITLE:=uuid
URL:=https://github.com/Tieske/uuid
DEPENDS:=+lua +luasocket
+ PKGARCH:=all
endef
define Package/uuid/description