aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2015-11-16 19:55:06 +0800
committerJeffery To <jeffery.to@gmail.com>2015-11-16 19:55:06 +0800
commit1440f75ac71e1b528763dd5c50b042b3066ba8f3 (patch)
treeef1cebd6b8d19f4c72db6b8bb684978679d3d2ef /lang
parenta6d7666c4cb38e9565e9a58b69909307a68229a7 (diff)
python-cffi: new package
From PyPI: Foreign Function Interface for Python calling C code. This depends on python-pycparser, which is in PR #1970 Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang')
-rw-r--r--lang/python-cffi/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/lang/python-cffi/Makefile b/lang/python-cffi/Makefile
new file mode 100644
index 000000000..68368d367
--- /dev/null
+++ b/lang/python-cffi/Makefile
@@ -0,0 +1,45 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=cffi
+PKG_VERSION:=1.3.0
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://pypi.python.org/packages/source/c/cffi
+PKG_MD5SUM:=a40ed8c8ac653c8fc7d5603711b06eaf
+
+PKG_BUILD_DEPENDS:=python python-setuptools
+
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
+
+include $(INCLUDE_DIR)/package.mk
+$(call include_mk, python-package.mk)
+
+define Package/python-cffi
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=python-cffi
+ URL:=http://cffi.readthedocs.org/
+ DEPENDS:=+libffi +python-light +python-pycparser
+endef
+
+define Package/python-cffi/description
+Foreign Function Interface for Python calling C code.
+endef
+
+define Build/Compile
+ $(call Build/Compile/PyMod,,install --prefix=/usr --root=$(PKG_INSTALL_DIR))
+endef
+
+$(eval $(call PyPackage,python-cffi))
+$(eval $(call BuildPackage,python-cffi))