aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorJavier Marcet <javier@marcet.info>2021-08-02 09:36:36 +0200
committerJosef Schlehofer <pepe.schlehofer@gmail.com>2021-08-03 16:17:35 +0200
commit0d4744f21432484f9c8a5b543098a3cd53a5ec45 (patch)
tree4e47dfdae865906327a9fbc2421509e40638b10f /lang
parentb98471e4123e184967471ebd4ebefc30ce9f7204 (diff)
python3-distro: update to version 1.6.0
- BACKWARDS COMPATIBILITY: - Deprecated the distro.linux_distribution() function. Use distro.id(), distro.version() and distro.name() instead [#296] - Deprecated Python 2.7, 3.4 and 3.5 support. Further releases will only support Python 3.6+ - ENHANCEMENTS: - Added type hints to distro module [#269] - Added __version__ for checking distro version [#292] - Added support for arbitrary rootfs via the root_dir parameter [#247] - Added the --root-dir option to CLI [#161] - Added fallback to /usr/lib/os-release when /etc/os-release isn't available [#262] - BUG FIXES: - Fixed subprocess.CalledProcessError when running lsb_release [#261] - Ignore /etc/iredmail-release file while parsing distribution [#268] - Use a binary file for /dev/null to avoid TextIOWrapper overhead [#271] - RELEASE: - Moved repository from nir0s/distro to python-distro/distro on GitHub. Signed-off-by: Javier Marcet <javier@marcet.info>
Diffstat (limited to 'lang')
-rw-r--r--lang/python/python-distro/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/lang/python/python-distro/Makefile b/lang/python/python-distro/Makefile
index bef80d63e..8d8aa1809 100644
--- a/lang/python/python-distro/Makefile
+++ b/lang/python/python-distro/Makefile
@@ -1,11 +1,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=python-distro
-PKG_VERSION:=1.5.0
-PKG_RELEASE:=3
+PKG_VERSION:=1.6.0
+PKG_RELEASE:=1
PYPI_NAME:=distro
-PKG_HASH:=0e58756ae38fbd8fc3020d54badb8eae17c5b9dcbed388b17bb55b8a5928df92
+PKG_HASH:=83f5e5a09f9c5f68f60173de572930effbcc0287bb84fdc4426cb4168c088424
PKG_MAINTAINER:=Javier Marcet <javier@marcet.info>
PKG_LICENSE:=Apache-2.0
@@ -20,7 +20,7 @@ define Package/python3-distro
CATEGORY:=Languages
SUBMENU:=Python
TITLE:=Distro - an OS platform information API
- URL:=https://github.com/nir0s/distro
+ URL:=https://github.com/python-distro/distro
DEPENDS:=+python3-light +python3-logging
endef